6.1 Bill To Country

We are on 5.2 and the country code is a drop-down and all of our
countries pulled over correctly.
I was working on a report yesterday and grouping customers by their
bill to country. I was suprised to find that many (over half) of our
customers had no value in the field. I looked at a few of them in
Vantage and lo and behold, there was a value in the Country drop down
list. After shaking off a moment of utter confusion, I tried re-
selecting the value in the drop down list and OK'd my way out of the
customer. Checked the report and it still didn't show. Then I tried
chaning it from USA to Mexico OK'd out and then Mexico did show up. I
went back in and changed it back to USA and then it was OK.

My theory is that during a previous upgrade the field changed from a
text box to a drop down list and during the conversion, the data
somehow showed up in the screen but didn't get written to the field
properly. Does that make sense? Can someone who has upgraded from 5
to 6.1 check their Bill To Country fields and see if they have the same
situation?

To fix the situation I have created a quick keys macro that will go
into the Bill To screen and change the country to Mexico, OK all the
way out, go back in and change it back to USA. I have about 1200
customers that should have a Bill to Country of USA, but instead it is
blank.

Thanks,

Brian Stenglein
Clow Stamping Co.
This is indeed what happened as the country field used to be a free form
text field. I forget which conversion it was however. Maybe from 3.0
to 4.0? Prior to the upgrade process we ran some reports to list all
the possible spellings of countrys (e.g. "U.S.", "U.S.A.", "USA",
"U.S.") and cleaned them up so that only the 'correct' countrys would be
populated into the Country master file during the conversion.

Mike

________________________________

From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf
Of Brian Stenglein
Sent: Tuesday, June 27, 2006 6:15 AM
To: vantage@yahoogroups.com
Subject: [Vantage] 6.1 Bill To Country



I was working on a report yesterday and grouping customers by their
bill to country. I was suprised to find that many (over half) of our
customers had no value in the field. I looked at a few of them in
Vantage and lo and behold, there was a value in the Country drop down
list. After shaking off a moment of utter confusion, I tried re-
selecting the value in the drop down list and OK'd my way out of the
customer. Checked the report and it still didn't show. Then I tried
chaning it from USA to Mexico OK'd out and then Mexico did show up. I
went back in and changed it back to USA and then it was OK.

My theory is that during a previous upgrade the field changed from a
text box to a drop down list and during the conversion, the data
somehow showed up in the screen but didn't get written to the field
properly. Does that make sense? Can someone who has upgraded from 5
to 6.1 check their Bill To Country fields and see if they have the same
situation?

To fix the situation I have created a quick keys macro that will go
into the Bill To screen and change the country to Mexico, OK all the
way out, go back in and change it back to USA. I have about 1200
customers that should have a Bill to Country of USA, but instead it is
blank.

Thanks,

Brian Stenglein
Clow Stamping Co.






[Non-text portions of this message have been removed]