Able to force DMT to keep leading spaces?

Does anyone know if there is there a way to force DMT to not drop leading spaces on the Supplier Part?

I’m trying to update records in the Supplier Price List, but about 400 records of the supplier part number start with a space, which when loaded into DMT (prior to processing the records) gets removed. This results in the error message “Supplier Part is a key column and cannot be changed” and the records are not updated. I have tried using an .xlsx and .csv format, with and without adding a leading apostrophe to signify it is text. None of those made any difference.

I’d prefer to not have to update each one of these records manually. Epicor Support was of no help on this topic.

I’ve always been too lazy to ask this question myself.

My story is that we had a bin created with a leading space. Not by me, I will say.

To cut to the chase*, there are times I do an “inventory transfer” (within same site) and I need to reference a bin (the bin ID) with a leading space and DMT ignores it and I have to do those transfers manually. And I get angry. And that’s my solution.

So, I’d also like to know if there is a way.

*OK, here’s the long version. I cleared out this bin and made it inactive. But it was still alphabetically the first bin in the warehouse. So lots of transactions went through it for a time - even after it was inactive, I am pretty sure. Before this, my first bin was called “0-DEFAULT” but in the arms race that was created, I now have a " 0-DEFAULT" bin (with a leading space). And there are times that I need to clean it out, but DMT wants to use the original 0-DEFAULT (no space). Such a pain.

1 Like

Can you use a double-quote around strings in the CSV to force preserve the leading space, or will DMT trim it regardless?
example, " ABCDE" If hard to see, there’s a double-quote, space, ABCDE

Why…why would you want to do this?

1 Like

Lol. I don’t want to, I have to, because someone else already entered the data with leading spaces and now I can’t update it en masse for that reason.

There has to be some way to tear this out by the root. Doubling down on or even just importing someone else’s poor practice is rarely a good idea.

1 Like

Can you use a double-quote around strings in the CSV to force preserve the leading space, or will DMT trim it regardless?
example, " ABCDE" If hard to see, there’s a double-quote, space, ABCDE

Hmm, I thought I had tried that, and just did to make sure. Unfortunately, this doesn’t work either. Get the error that it cannot find that supplier part number.

Good thought, though!

1 Like

Agreed. And that’s why while I discuss if there’s a mass solution with you all, I’m manually going through and recreating these without the leading space.

Maybe with the single quote text literal


^ space after the apostrophe/single quote? Never tried this myself

Yeah, that was my first thought, too, but no go.

Does Epicor have a data fix for leading spaces on this table? They do for others. You might want to hit them up.

I asked, but they had no idea what I was talking about, so I moved on.

Before you paste the data into the DMT excel file make the Column a Text column for the supplier part number. I think thats how we have done it in the past.

1 Like

Are you certain it is DMT ‘fixing’ your part number for you and not Excel or your text editor of choice?

Try doing your work in something like Access that will just leave your data as is and won’t try and ‘help’ you like excel does.

Almost thought this was it, but it was finding entries where someone had already entered them without the space. Tried it out with one that only had a supplier part number with a space and it cannot then find the supplier part without the leading space.

And are you sure its a regular old space char (ASCII 32d or 0x20)? And not a special space like ASCII 160 (0xA0 - the non-breaking space)

Using the UI, can you select the supplier part number by typing it in (with the leading space)?

I often copy “text” to the clipboard and then use a freeware Clipboard viewer. I had to do this just this morning to findout what character is used to separate the text lines in a Changelog record. It is ASCII 30 (0x1E - the Record Separator control code)

Yes. I double checked this with both the .xlsx and .csv files. The field remains with the leading zero, even after closing and re-opening the file.

Great suggestions. From what I’m able to determine, it looks like a regular old space.

Unable to try searching in the UI by typing, because it’s loaded as soon as you enter our part number for the given supplier.

If the DMT doesn’t work out, you could always make an updatable dashboard do a paste update.

  1. Let the UI auto load the supplier PartNum.
  2. Double click the supllier PartNum to select it all.
  3. Copy to the clipboard.
  4. In excel, format a cell as TEXT
  5. Select that cell and hit F2 to enter editing mode
  6. Paste the clipboard (use Ctrl+V) into the cell
  7. Make a formula in the cell below it with =CODE(LEFT(<ref to cell you pasted into>,1))

That will show you the character code for the first character in the supplier partNum

1 Like