Adding a BAQ report to a process set - exception error - 10.2.400.8

I am tryting to add a BAQ report to a process set and it generates an exception error in the server event log, which to summarise contains the following message:

“System.Data.SqlClient.SqlException: String or binary data would be truncated.”

I have tried to add other BAQ reports and get the same error.

I have tried adding breakling and routing to the BAQ report and get the same error

I have tried regular epicor system reports and have succeeded in adding them.

I can add BAQ reports as regular scheduled tasks.

Has anyone else experienced this with BAQ reports??

@richardh

I’ve seen this several times before myself, and it appears to have something to do with either the BAQ report description or the process set description. A possible resolution is making either or both descriptions a single character, and then saving it.

Thank you, Matthew.

That’s the issue! The BAQ report description length

@timshuwy @Chris_Conn @josecgomez If I may bring you in this discussion as well, is this matter with the report description throwing an error with the Process Set a known issue in Epicor?

I have a support case raised with Epicor as well. Let’s see what they say…

I am not certain that this is a known issue, but it is definitely NOT the desired result and should be reported as a bug. This is not an “enhancement request”.

1 Like

The response I have got is; upgrade to 10.2.400.40 - this will probably fix it!

Also apparently BAQ reports are being deprecated in favour of a new custom RDD approach.

1 Like

We had a similar question the other day, and I researched with Development. They said that BAQ Reports are not being phased out.

Apparently there is an open problem: PRB0218012