AP Invoice batch

I have a batch that is hanging open. It says the person who created it is still “active” in it but they aren’t even here - they are on vacation. I’d like to get it posted if necessary for my month-end tomorrow. Is there a way to “clear” it so I can pull up the batch and check it out? TIA!!

Try stopping the Task Agent service, restart it and it should clear the hanging task. Then you have to hope the user has left the group so it is accessible for you to post it.

Thank you. Do you mean Task Agent on the server? Is that the same as Task Manager on my laptop? We have no IT department here so I appreciate all the guidance. :slight_smile:

No, the Task Agent is a Windows service running on the application server. You can access it from Control Panel / Administrative Tools / Services. From there, highlight the service, click restart service.

Please make sure there is no other active process in system monitor (click actions / display all tasks) while you restart the Task Agent service.

Do you know the person’s log in? you could log in as them to work on the batch.

You could also clear their password from user account maintenance.

Unfortunately, no I do not know their login. :frowning:

OK - tried the stop/restart per the suggestion above. It didn’t work. Any other thoughts or suggestions?? Thanks!!

The task remains active in System Monitor? Next thing is to go under System Setup / Security Maintenance / User Account Security Maintenance, then select the end user and click expire password. Now log in Epicor with that user account and enter a new password. Once you are logged in, try deleting the task from System Monitor.


Thanks! I’ll give that a shot. This is what I’m seeing and trying to correct. It won’t let me access the AP batch at the moment.


You’ll have to access it logged in the system as Chris.

That worked! Thanks so much for the help!!! Have a great weekend.

1 Like

You should NEVER use a direct SQL update on your E10 DB… OK!

Update Erp.ApInvGrp
Set ActiveUserID = ‘’
Where GroupID = ‘the name of the group that you want to unlock’

A friend said that this works :wink:

1 Like

I’m curious how you would even run a direct sql update on the database…


1 Like

And like editing the registry…

“If you don’t know how to do it, you absolutely shouldn’t even consider it.”

1 Like