AR Aging, exclude statements for credit balances

I’m looking for a way to exclude credit balances when we print our statements. When generating, I’ve added in tables with criteria defined, but I think Epicor treats those as outer joins. When I try to filter in my RDL, I get the no data error:

image

I would rather it give me the “No Records Found” in the system monitor. Is there a way to do this? I know we can format the report to generate a message in the event of no data, but we don’t want to e-mail that out.

TIA!

1 Like

Did you try modifying the SQL in the report?

Yes, the background data is there (in the Report Database), but when I add the commands to the SQL in the RDL it gives me the #Error because there is no data returned for that customer in the dataset. I think the #Error comes because of the APR seeing the customer in the dataset, but then the report filters it out.

If I run the report with no routing, then I get no #Error message.

Can you exclude them in the Report Style’s Breaking/Routing process?

1 Like

The issue is it depends on the summation of 6 fields. I keep looking for something I can use.

Maybe I can create a UD field that can set in a process to be run before statements. I can then use that in the APR.

Another option is to apply all credit memos to the open invoices. Then you would only have invoices with open balances.
Also, take a look at the GlbCustCred (or something close to that) table. It will show what the net open invoice amount is.

I can try to change the RDD and see if I can use that in the APR.

We do this in the Report Style’s Breaking/Routing process

If the value of our statement are below a certain value they don’t go anywhere

I had used the GlbCustCredit table before, but this time I used it in the condition in the APR.

Exactly what we needed. Thanks!

1 Like