BAQ or User Error in 9.05.600C?

PayRollDate and ClockInDate give the same results. Nothing.

I changed the parameters from:

DataType: Date
Format: x(8)
Mandatory: Yes (Checked)
Editor Type: Common Editor

To this:
DataType: Date
Format: 99/99/99
Mandatory: Yes (Checked)
Editor Type: Common Editor

And this:
DataType: DateTime
Format: 99/99/99 HH:MM:SS.SSS
Mandatory: Yes (Checked)
Editor Type: Common Editor

The latter is how it is stored in the SQL tables.

Neither works.

Jeff Sanders





--- In vantage@yahoogroups.com, "Scott Litzau" <scott.litzau@...> wrote:
>
> I think you want to use ClockInDate field as the parameter, not the
> PayRollDate.
>
> Scott
>
> -----Original Message-----
> From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf Of
> jeffery_p_sanders
> Sent: Monday, August 23, 2010 10:21 AM
> To: vantage@yahoogroups.com
> Subject: [Vantage] BAQ or User Error in 9.05.600C?
>
> I inserted the LaborHed and LaborDtl tables in the phrase builder. They are
> linked. I displayed fields and analyzed\tested the BAQ. Everything works
> fine. The results show about 10 records inbetween the 8/12/2010 and
> 8/20/2010 Payroll dates.
>
> Next I place two criteria on the LaborDtl table:
>
> Criteria 1
> --------------------------
> Field Name: PayRollDate
> Comparison: >=
> Filter Value: {StartDate} Specified Parameter
>
> Criteria 2
> --------------------------
> And Or: And
> Field Name: PayRollDate
> Comparison: <=
> Filter Value: {EndDate} Specified Parameter
>
> I defined the Parameters as:
> DataType: Date
> Format: x(8)
> Mandatory: Yes (Checked)
> Editor Type: Common Editor
>
> When I run the BAQ, it asks me for the start and end dates. I select them
> as 8/1/2010 and 8/31/2010. I get no results or errors.
>
> What am I doing wrong?
>
> Jeff Sanders
>
>
>
>
>
>
>
>
> ------------------------------------
>
> Useful links for the Yahoo!Groups Vantage Board are: ( Note: You must have
> already linked your email address to a yahoo id to enable access. )
> (1) To access the Files Section of our Yahoo!Group for Report Builder and
> Crystal Reports and other 'goodies', please goto:
> http://groups.yahoo.com/group/vantage/files/.
> (2) To search through old msg's goto:
> http://groups.yahoo.com/group/vantage/messages
> (3) To view links to Vendors that provide Vantage services goto:
> http://groups.yahoo.com/group/vantage/linksYahoo! Groups Links
>
I inserted the LaborHed and LaborDtl tables in the phrase builder. They are linked. I displayed fields and analyzed\tested the BAQ. Everything works fine. The results show about 10 records inbetween the 8/12/2010 and 8/20/2010 Payroll dates.

Next I place two criteria on the LaborDtl table:

Criteria 1
--------------------------
Field Name: PayRollDate
Comparison: >=
Filter Value: {StartDate} Specified Parameter

Criteria 2
--------------------------
And Or: And
Field Name: PayRollDate
Comparison: <=
Filter Value: {EndDate} Specified Parameter

I defined the Parameters as:
DataType: Date
Format: x(8)
Mandatory: Yes (Checked)
Editor Type: Common Editor

When I run the BAQ, it asks me for the start and end dates. I select them as 8/1/2010 and 8/31/2010. I get no results or errors.

What am I doing wrong?

Jeff Sanders
I think you want to use ClockInDate field as the parameter, not the
PayRollDate.

Scott

-----Original Message-----
From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf Of
jeffery_p_sanders
Sent: Monday, August 23, 2010 10:21 AM
To: vantage@yahoogroups.com
Subject: [Vantage] BAQ or User Error in 9.05.600C?

I inserted the LaborHed and LaborDtl tables in the phrase builder. They are
linked. I displayed fields and analyzed\tested the BAQ. Everything works
fine. The results show about 10 records inbetween the 8/12/2010 and
8/20/2010 Payroll dates.

Next I place two criteria on the LaborDtl table:

Criteria 1
--------------------------
Field Name: PayRollDate
Comparison: >=
Filter Value: {StartDate} Specified Parameter

Criteria 2
--------------------------
And Or: And
Field Name: PayRollDate
Comparison: <=
Filter Value: {EndDate} Specified Parameter

I defined the Parameters as:
DataType: Date
Format: x(8)
Mandatory: Yes (Checked)
Editor Type: Common Editor

When I run the BAQ, it asks me for the start and end dates. I select them
as 8/1/2010 and 8/31/2010. I get no results or errors.

What am I doing wrong?

Jeff Sanders








------------------------------------

Useful links for the Yahoo!Groups Vantage Board are: ( Note: You must have
already linked your email address to a yahoo id to enable access. )
(1) To access the Files Section of our Yahoo!Group for Report Builder and
Crystal Reports and other 'goodies', please goto:
http://groups.yahoo.com/group/vantage/files/.
(2) To search through old msg's goto:
http://groups.yahoo.com/group/vantage/messages
(3) To view links to Vendors that provide Vantage services goto:
http://groups.yahoo.com/group/vantage/linksYahoo! Groups Links