BAQ report - information missing for only 1 user ID

Thanks to Jeff Lehr for solving this for me. Thought all of you might be interested in the solution.

This relates to the CRM module and Workforce authorized users.

The reason the report was eliminating data when run by User X was because User X erroneously was not an authorized user of one workforceID. That workforceID was the salesperson on several customer accounts. So when the order entry report was run by User X, if there were any orders from customers who had this WorkforceID as their salesperson, the data was filtered out and not included in the query results so it was not available to be displayed in the report.

Thanks to everyone for all your suggestions!



--- In vantage@yahoogroups.com, "homestyleindustries" <homestyleindustries@...> wrote:
>
> Virginia,
>
> I am not sure if this will fix your problem but it is worth a shot. Pull up the report in Crystal Reports. Go to File and make sure the "Save Data with Report" option is not checked, save and retry.
>
> --- In vantage@yahoogroups.com, "Virginia" <vjoseph@> wrote:
> >
> > We have a user that wrote a BAQ, created a BAQ report, and added it to the menu maintenance - accessible to everyone. The report is for order entry within any time frame defined by the start & end dates entered when the report is run. The start & end dates use the OrderHed.OrderDate field to determine if the order value should be included in the report.
> >
> > The report runs fine except for one exception. All user ID's run the report for 01/01/10 - 01/14/10 and get the same order entry value. The exception is when the report is run and the user ID in use is the User ID of the person who created the BAQ and the report!
> >
> > How is this even possible? What am I missing?
> >
> > Virginia Joseph
> > vjoseph@
> > 440-543-8157
> >
>
We have a user that wrote a BAQ, created a BAQ report, and added it to the menu maintenance - accessible to everyone. The report is for order entry within any time frame defined by the start & end dates entered when the report is run. The start & end dates use the OrderHed.OrderDate field to determine if the order value should be included in the report.

The report runs fine except for one exception. All user ID's run the report for 01/01/10 - 01/14/10 and get the same order entry value. The exception is when the report is run and the user ID in use is the User ID of the person who created the BAQ and the report!

How is this even possible? What am I missing?

Virginia Joseph
vjoseph@...
440-543-8157
Virginia,

I am not sure if this will fix your problem but it is worth a shot. Pull up the report in Crystal Reports. Go to File and make sure the "Save Data with Report" option is not checked, save and retry.

--- In vantage@yahoogroups.com, "Virginia" <vjoseph@...> wrote:
>
> We have a user that wrote a BAQ, created a BAQ report, and added it to the menu maintenance - accessible to everyone. The report is for order entry within any time frame defined by the start & end dates entered when the report is run. The start & end dates use the OrderHed.OrderDate field to determine if the order value should be included in the report.
>
> The report runs fine except for one exception. All user ID's run the report for 01/01/10 - 01/14/10 and get the same order entry value. The exception is when the report is run and the user ID in use is the User ID of the person who created the BAQ and the report!
>
> How is this even possible? What am I missing?
>
> Virginia Joseph
> vjoseph@...
> 440-543-8157
>