Barcoding Delay

[Cut & Paste from previous topic]

I'm using the Symbol scanners as well. Through a lot of trial and error, I have a list of setup scans to set parameters starting with the default settings. I'm not sure which ones are the critical parameters but got tired of playing with it. It takes maybe two minutes if that to setup and it doesn't happen that often. I'm not going to pretend I don't have the slightest idea of what any of these parameters are for but nevertheless, it works for me. YMMV

You can download the manual with the setup barcodes from the Symbol website.

Here is my list:

SET DEFAULTS

Com Options
Standard Interfaces Wedge
Terminal Type: AT
Country Code: North American
Keystroke Delay: 0 ms
Ignore Unknown Chars: Enable
Caps Lock: Disable
Inter Scan Code Delay: Disable
Enable Alt Numeric Keypad: Enable
Caps Lock Override: Disable
Function Key Mapping: Enable
FN1 Substitution: Disable
Send Make and Break: Send Make and Break
Convert Wedge Data: Convert Wedge Data to Upper Case

Single RS232C
Baud Rate: 9600 Baud
Parity: None
Hardware Handshaking: None
Software Handshaking: None
Stop Bits: 1 Bit
Data Bits: 8 Bits
RTS State: Low
Serial Response Timeout: 2 sec
Retail Format Type: Standard Host (None)
Intercharacter Delay: 0 ms
Beep on Bel: Disable
Check Receive Errors: Enable
Ignore Unknown Chars: Enable
Nixdorf Beep/LED Options: Normal Operation

USB Configuration
USB Type: Hardware Default
Country Code: North American
Keystroke Delay: 0 ms
Ignore Unknown Chars: Enable
Caps Lock Override: Disable
SNAPI Status Handshake (if supported): Enable
Emulate Keypad: Enable
FN1 Substitution: Disable
Function Key Mapping: Enable
Simulated Cap Lock: Disable
Convert Case: Convert all to Upper Case

IBM 46xx
Port Address: None Selected
Convert Unknown Code Types to Code 39: Enable

Wand Emulation
Terminal Type: Symbol
Leading Margin: 80 ms
Wand Bar Out: High
Ignore Unknown Chars: Enable
Convert to Code 39: Enable
Full ASCII Conversion: Enable

Symbologies
Linear Barcodes
Code 39: Enable
Code 39 Full Ascii: Enable
Trioptic Code 39: Disable
I 2 of 5: Disable


--- In vantage@yahoogroups.com, "drew.pete" <drew.pete@...> wrote:
>
> I set the pause duration on my scanner but am unfamiliar with the syntax in the code. Would you mind sharing the syntax you used for the delay?
>
> Thanks
We are currently working on expediting the issuing material process. On the issue material form we have the tabstops set up exactly the way we want them. When we go through a manual sequence it works perfectly - the tabstop order that is. However, when we include the tabstops in the crystal report barcode it seems to skip over the "From" group box when shooting it with the gun. I'm guessing that when we scan the barcode it does fine up until after it selects the material to issue - it then jumps over the "From" group box because it hasn't returned the method calls to get data for the objects in that group box before the data is sent from the gun. In short, I think the data from the gun is coming faster than the method calls invoked after selecting the material. Is there anyway to set a lag so the method calls finish and then the data from the scanner continues to populate? Or will I have to section the barcoding in two parts: before/including and after the material selection? Any ideas are greatly appreciated.

Thanks,

Drew
I am not sure what kind of barcode scanner you have, but you can adjust the keystroke delay on a lot of them. We use the Symbol LS2208 and in the manual there are a bunch of barcoded parameters that can be set. On this model you can set the keystroke delay to 0,20, and 40 milliseconds. Not sure if that is enough of a delay but it is worth a shot.

--- In vantage@yahoogroups.com, "drew.pete" <drew.pete@...> wrote:
>
> We are currently working on expediting the issuing material process. On the issue material form we have the tabstops set up exactly the way we want them. When we go through a manual sequence it works perfectly - the tabstop order that is. However, when we include the tabstops in the crystal report barcode it seems to skip over the "From" group box when shooting it with the gun. I'm guessing that when we scan the barcode it does fine up until after it selects the material to issue - it then jumps over the "From" group box because it hasn't returned the method calls to get data for the objects in that group box before the data is sent from the gun. In short, I think the data from the gun is coming faster than the method calls invoked after selecting the material. Is there anyway to set a lag so the method calls finish and then the data from the scanner continues to populate? Or will I have to section the barcoding in two parts: before/including and after the material selection? Any ideas are greatly appreciated.
>
> Thanks,
>
> Drew
>
--- In vantage@yahoogroups.com, "drew.pete" <drew.pete@...> wrote:
>
> We are currently working on expediting the issuing material process. On the issue material form we have the tabstops set up exactly the way we want them. When we go through a manual sequence it works perfectly - the tabstop order that is. However, when we include the tabstops in the crystal report barcode it seems to skip over the "From" group box when shooting it with the gun. I'm guessing that when we scan the barcode it does fine up until after it selects the material to issue - it then jumps over the "From" group box because it hasn't returned the method calls to get data for the objects in that group box before the data is sent from the gun. In short, I think the data from the gun is coming faster than the method calls invoked after selecting the material. Is there anyway to set a lag so the method calls finish and then the data from the scanner continues to populate? Or will I have to section the barcoding in two parts: before/including and after the material selection? Any ideas are greatly appreciated.
>
> Thanks,
>
> Drew
>

Ok so the delay isn't necessary anymore. I'm cutting it short in terms of the amount fields I want to populate. I have LS4071 scanner and got it working with Code 39. It recognizes tabstops in notepad just perfectly but when I scan the same barcode into the epicor form it doesn't perform the tabstops. I'm on 8.03.408b.

Here is the code I'm using for the barcode....

"*" + Trim(ToText({JobHead.JobNum})) + "$I" + "$I" + Trim(ToText({JobMtl.AssemblySeq},0)) + "$I" + "$I" + Trim(ToText({JobMtl.MtlSeq},0)) + "*"

Anyone have any ideas?

Thanks,

Drew
I did something similar on Job Travelers and I did need to program the scanner with a delay to allow time for Vantage to "keep up". I set it to Medium Delay (20 msec) and it solved my problems.


--- In vantage@yahoogroups.com, "drew.pete" <drew.pete@...> wrote:
>
>
>
> --- In vantage@yahoogroups.com, "drew.pete" <drew.pete@> wrote:
> >
> > We are currently working on expediting the issuing material process. On the issue material form we have the tabstops set up exactly the way we want them. When we go through a manual sequence it works perfectly - the tabstop order that is. However, when we include the tabstops in the crystal report barcode it seems to skip over the "From" group box when shooting it with the gun. I'm guessing that when we scan the barcode it does fine up until after it selects the material to issue - it then jumps over the "From" group box because it hasn't returned the method calls to get data for the objects in that group box before the data is sent from the gun. In short, I think the data from the gun is coming faster than the method calls invoked after selecting the material. Is there anyway to set a lag so the method calls finish and then the data from the scanner continues to populate? Or will I have to section the barcoding in two parts: before/including and after the material selection? Any ideas are greatly appreciated.
> >
> > Thanks,
> >
> > Drew
> >
>
> Ok so the delay isn't necessary anymore. I'm cutting it short in terms of the amount fields I want to populate. I have LS4071 scanner and got it working with Code 39. It recognizes tabstops in notepad just perfectly but when I scan the same barcode into the epicor form it doesn't perform the tabstops. I'm on 8.03.408b.
>
> Here is the code I'm using for the barcode....
>
> "*" + Trim(ToText({JobHead.JobNum})) + "$I" + "$I" + Trim(ToText({JobMtl.AssemblySeq},0)) + "$I" + "$I" + Trim(ToText({JobMtl.MtlSeq},0)) + "*"
>
> Anyone have any ideas?
>
> Thanks,
>
> Drew
>
I set the pause duration on my scanner but am unfamiliar with the syntax in the code. Would you mind sharing the syntax you used for the delay?

Thanks

--- In vantage@yahoogroups.com, "aimee.grebe" <aimee.grebe@...> wrote:
>
> I did something similar on Job Travelers and I did need to program the scanner with a delay to allow time for Vantage to "keep up". I set it to Medium Delay (20 msec) and it solved my problems.
>
>
> --- In vantage@yahoogroups.com, "drew.pete" <drew.pete@> wrote:
> >
> >
> >
> > --- In vantage@yahoogroups.com, "drew.pete" <drew.pete@> wrote:
> > >
> > > We are currently working on expediting the issuing material process. On the issue material form we have the tabstops set up exactly the way we want them. When we go through a manual sequence it works perfectly - the tabstop order that is. However, when we include the tabstops in the crystal report barcode it seems to skip over the "From" group box when shooting it with the gun. I'm guessing that when we scan the barcode it does fine up until after it selects the material to issue - it then jumps over the "From" group box because it hasn't returned the method calls to get data for the objects in that group box before the data is sent from the gun. In short, I think the data from the gun is coming faster than the method calls invoked after selecting the material. Is there anyway to set a lag so the method calls finish and then the data from the scanner continues to populate? Or will I have to section the barcoding in two parts: before/including and after the material selection? Any ideas are greatly appreciated.
> > >
> > > Thanks,
> > >
> > > Drew
> > >
> >
> > Ok so the delay isn't necessary anymore. I'm cutting it short in terms of the amount fields I want to populate. I have LS4071 scanner and got it working with Code 39. It recognizes tabstops in notepad just perfectly but when I scan the same barcode into the epicor form it doesn't perform the tabstops. I'm on 8.03.408b.
> >
> > Here is the code I'm using for the barcode....
> >
> > "*" + Trim(ToText({JobHead.JobNum})) + "$I" + "$I" + Trim(ToText({JobMtl.AssemblySeq},0)) + "$I" + "$I" + Trim(ToText({JobMtl.MtlSeq},0)) + "*"
> >
> > Anyone have any ideas?
> >
> > Thanks,
> >
> > Drew
> >
>
You set the delay by scanning a code in the little booklet that came with the scanner.






________________________________
From: drew.pete <drew.pete@...>
To: vantage@yahoogroups.com
Sent: Tue, April 20, 2010 4:46:40 PM
Subject: [Vantage] Re: Barcoding Delay


I set the pause duration on my scanner but am unfamiliar with the syntax in the code. Would you mind sharing the syntax you used for the delay?

Thanks

--- In vantage@yahoogroups .com, "aimee.grebe" <aimee.grebe@ ...> wrote:
>
> I did something similar on Job Travelers and I did need to program the scanner with a delay to allow time for Vantage to "keep up". I set it to Medium Delay (20 msec) and it solved my problems.
>
>
> --- In vantage@yahoogroups .com, "drew.pete" <drew.pete@> wrote:
> >
> >
> >
> > --- In vantage@yahoogroups .com, "drew.pete" <drew.pete@> wrote:
> > >
> > > We are currently working on expediting the issuing material process. On the issue material form we have the tabstops set up exactly the way we want them. When we go through a manual sequence it works perfectly - the tabstop order that is. However, when we include the tabstops in the crystal report barcode it seems to skip over the "From" group box when shooting it with the gun. I'm guessing that when we scan the barcode it does fine up until after it selects the material to issue - it then jumps over the "From" group box because it hasn't returned the method calls to get data for the objects in that group box before the data is sent from the gun. In short, I think the data from the gun is coming faster than the method calls invoked after selecting the material. Is there anyway to set a lag so the method calls finish and then the data from the scanner continues to populate? Or will I have to section the barcoding in two parts: before/including and
after the material selection? Any ideas are greatly appreciated.
> > >
> > > Thanks,
> > >
> > > Drew
> > >
> >
> > Ok so the delay isn't necessary anymore. I'm cutting it short in terms of the amount fields I want to populate. I have LS4071 scanner and got it working with Code 39. It recognizes tabstops in notepad just perfectly but when I scan the same barcode into the epicor form it doesn't perform the tabstops. I'm on 8.03.408b.
> >
> > Here is the code I'm using for the barcode....
> >
> > "*" + Trim(ToText( {JobHead. JobNum})) + "$I" + "$I" + Trim(ToText( {JobMtl.Assembly Seq},0)) + "$I" + "$I" + Trim(ToText( {JobMtl.MtlSeq} ,0)) + "*"
> >
> > Anyone have any ideas?
> >
> > Thanks,
> >
> > Drew
> >
>







[Non-text portions of this message have been removed]