Bartender FTP path changed

After the 2026.100.7 upgrade our Bartender FTP Output path changed from a UNC to a specific prefix.

The new path is /epi/ftp/Bartender

We are unable to save any output location value other than “/epi/ftp” or “/epi/fs” (we are using FTP). If any other value, including “/epi/ftp/Bartender” (even with an extra slash at the end), is entered, an error is produced “Invalid Output Location”. This occurs in both Kinetic and Classic screens (we are deferring 2026 update until October).

When we try to export to our regular FTP location, which would be “/epi/ftp”, the task errors with “Access is denied” permissions error. We’ve opened an Epicare ticket for the issue but no help yet since the problem occurred after the weekend update. Our label printing is still down. I will update if we find a solution.

Mr. Dylan: Have you tried using an FTP program FileZilla,WFTP, Etc to manually log on and add a folder called Bartender? Then include Bartender path in your Output ?

Does the folder exist? Verify.

Unless you already have this installed. I’d stay away from this one as the download now are full of malware.

I don’t use FileZilla for that reason-- I use WinSCP. And yes, I have created multiple folders and tried each. Same error: Invalid Output Path. If I use the root “/epi/ftp” (we used to just use the root folder before the linux update), the task errors with “Access Is Denied”. Hoping it’s simply a permissions debacle which can be resolved by Epicor. Awaiting an update from Support.

I am not sure this will help since we don’t use the FTP portion, but our custom label program drops to Epicor’s Azure File Share and our links were converted like so:

from:

\\tenantid.file.core.windows.net\tenantid\Pilot\Bartender\

to:

/epi/fs/Pilot/Bartender/

It might be a similar translation for the FTP side of things.

Looks like Epicor misconfigured our servers when they performed the update (I guess it’s no surprise there, we have been unable to utilize Epicor Functions Maintenance properly for nearly 3 years, misconfiguration issues still ongoing with no fix in sight).

We were able to get them to somehow correct our PILOT environment, but our Live/Production environment remains disconnected from our FTP, and we still cannot print bartender labels (have not been able to since Monday). They have been incapable of resolving our configuration and getting us reconnected to our FTP.

Are we the only ones who completely lost access to their FTP since Monday? I have a hard time accepting we are the only customer with these crazy configuration issues which are seemingly impossible for them to resolve. Company is suffering pretty badly with no ability to print our labels still.

How does this work in Multi Company, where you might have multiple Bartender Integrations. Large enterprises dumped it into a sub folder prefixed with Company, different Integrations monitoring different folders.

Can you try getting setup with an Azure File Share? That’s what we are on. Our Print Server connects to the Azure File Share to look for the BT Drop Files, then processes them and moves them to a local folder on the print server. We were never even offered an FTP connection, I wonder why?

Same - onprem BT and cloud Kinetic - Azure FS worked OK post-Linux once paths were squared.

Good quesitons- Apparently they had the FTP Set up with Epicor when they went live back in 2018 (before my time at this company). I didn’t realize this was something archaic getting phased out. We might need to explore having them change it to an Azure File Share instead since the FTP seems to not jive with our Epicor servers any more. We had a complete system outage for an hour today while they attempted to resolve the FTP issues. No dice. We might have to explore this if FTP is no longer a viable option. I don’t have an opinion on it either way, just want our server configured correctly and working as expected.

It’s rock solid for us. Sounds more like user error to me. (Not yours)

Ask for it and get it setup. It is solid for us.

Epicor Support got our FTP connection fixed up in our Live environment late on Friday, thanks to some great effort by Veronica and her team, so shout out to Veronica for being a rockstar for us :partying_face: . The issue was that Epicor did not set up access to our FTP in our environments after the Linux update over last weekend, and that took a week to resolve. Once we had the right support team on the issue, progress went a bit quicker but required a few hours of server downtime overall.

Everyone was under a lot of pressure with the week of label printing down last week- apologies for the complaining. Difficult situation all around.

Now that our FTP is back up and Bartender is spitting out labels regularly again, we probably will not be looking to change to the Azure File Share at this time, but I’ll keep an open mind going forward if we have any more issues with FTP :sweat_smile: Thanks for the help folks.