BPM: Linking an in-trans directive to a standard directive

Hi folks, I’m having trouble getting an in-trans directive to read a standard directive from the kinetic form:

I made an intrans directive and added a box for ‘enable standard directive’ but I don’t see the option to specify the standard directive I want to use:

In the screenshot you can see both the in-trans and standard directive on the left, but where can I designate the standard directive as a post-process directive? The order of the in-trans directive is 10 and the standard directive is 11. There are some posts related to this here, but they use the classic form and I need to use the kinetic form.

I don’t know if the kinetic version is different, but in classic you always determine that on the post procesing side. In the criteria there is a “Has been enabled by ____ directive” or something to that effect. You pick the pre-processing BPM in that criteria in the Post-Process. You don’t set it in the pre-processing.

Also, I’ve never done that with a Data directive. So I may be full of :poop:


Yeah I’ve seen mention on that ‘has been enabled by xxx directive’ here on the forum but it’s all classic form related. In the kinetic form, data directives and bpm studio are merged into one.

In my standard directive when I add a condition, none of the options I can choose deal with directives. And I can’t see where else to set that type of option.

Looks like Kinetic is missing that option. You’ll have to use the classic screen to make that if you need it. I’d put a ticket in for that.

Even getting back to the classic forms is not a simple task. In the smart client when you open bpm designer/studio, a msg at the top asks if you want to switch to the kinetic form, and if you choose that option there’s no way to go back quickly even after logging out and back in.

If you go here, instead of the BPM studio, it still doesn’t open in classic?

BPM designer studio doesn’t exist in classic.

That opens in the kinetic form. I think the majority of the users here are using onprem Kinetic still. For cloud kinetic, switching back and forth between kinetic forms and classic in the smart client is not an easy thing to do. Once you pick one you’re locked in to it.

Did you look at this setting?

hold alt when you click on the menu item. Then change the setting that pops up to classic. Then close the screen and re-open.

1 Like

You are my new favorite person, it worked! Thanks so much.

1 Like

If you find discrepancy with Kinetic BPM designer, please report it to support.

1 Like