Cannot seem to populate dataview via the tableset output of a function

I am struggling with populating a dataview from the results of an erp-function. I’ve read through a few posts on here but unfortunately have had no luck.

Here is the result from the function and error message:

The response from the function event and parameter setup is here:
image

And finally, here is the data view called CurrentSerials:

The parameter returned from the functon is called serials and is a TableSet and not a dataset:
image

Try removing SerialNo from the parameter name section.

1 Like

Thanks for the suggestion. Unfortunately it hasn’t helped.

1 Like

try changing parse from to returnObj

might need param name to be serials

Been a bit

Unfortunately still the same result

image

I have noticed the error message talk about actionResult.serials whereas the returnObj returns null:

take out serials, leave returnObj

Grasping

Unfortunately still the same issue, I feel like I’ve tried every combination the past day or so on and off and unfortunately no luck. Seems highly unlikely I’ll be able to get this approach to work.

I dunno. Someone more experienced will probably be along shortly.

It would be helpful to see the return data from your rest call (in the network tab of the browser dev tools)
It looks like you have a data set called serials with a table called SerialNo that you’re putting into a dataview called CurrentSerials… You might try returnObj.serials in the Parse from Response Path to ‘navigate’ to your nested table

I’ve tried changing the Response Path to returnObj.serials like suggested and still unfortunately nothing and the same error. Here’s the response data. I cannot see returnObj but just serials:

So there definitely is not a returnObj there… which makes your original configuration look correct
The root is actionResult, so maybe try actionResult.serials?

If that doesn’t do it, then I would look into using a separate widget for rolling your data into your data view. something like dataview-copy

1 Like

Try this

Parse from response path: serials
Parameter name: SerialNo

Unfortunately still no luck following both suggestions

Clear Parse From and add serials to Parameter Path

Also select a merge behavior

2 Likes