Classic Web Access Azure Auth

We are in the middle of testing out an Upgrade to 2021.2.16 a few months ago I stood up a test server with an earlier version of 2021. I was able to get Azure AD Login working on the Classic web but now I cannot for the life of me figure it out. everything else works for Azure AD Login Except Data Discovery but it works in a round about way. Data Discovery requires me to login to Kinetic UI and click the icon to go to Data Discovery going directly to the URL gives an application offline error and no azure login.

Per Epicor Docs I have my app registration setup
however trying to visit https://SERVERNAME/KineticERP-EWA/ice.ewa.sysloginazure.aspx it takes me to a page asking for a Epicor Tenant ID The Azure Details are entered into the Database via the Azure AD settings so the tenant ID should already be there and in the past I just had a login button that upon clicking it took me through the Azure AD login Process does this no longer work or is there something I am missing if I enter our Azure Tenant ID in here it just says its not valid?

I sense that when you deploy EDD that the config file with those settings doesn’t have that web address in it or somehow isn’t routing to that AD auth.

Have you confirmed that EDD works with Azure AD Login?

Sorry it took me a Few days to get Back I’m our IT Admin so I’ve been busy. I was able to get this to work I had to edit the web.config on the EWA deployment to tell it to use Azure Auth and it worked fine. so Kinetic and EWA both work with Azure Auth.

However EDD still doesn’t work by going directly to it https://domain/KineticERPTest-EDD/ still give Application Offline error which i can click ok then I’m presented with a username and password page but that is not Azure login.

If i go to the Kinetic Interface https://domain/KineticERPTest and click the login button I’m taken to azure to perform login then if I go to https://domain/KineticERPTest-EDD after login it works just not by going directly.

1 Like