Cleaning Up ECORev Table

Hi everyone!
I am working on a custom dashboard that allows users to easily add an operation to a part/revision. But It looks like I have a few parts in my ECORev table, and that is giving me a multiple records error in my dashboard.

How can I clean up the ECORev table? Is there a BO I am missing that helps keep this table cleaned up?

Thanks for your time!
Nate

I found a workaround to manually remove the ECORev entries.
Open Engineering Workbench.
Open your group.
Click Actions > Check Out Part.
Enter part number and select the correct revision.
Check it out to your group.
Click on Actions > Revision > Undo Check out.

This should remove any lingering records from ECORev. I would still like to know the correct BO for this.

I am still finding a value in ECORev, even when I have removed the appropriate records from ECORev.

Here is my setup.
I use GetDatasetForTree BO from EngWorkbench. I assign this tableset to tsWB.
Next I run a message widget that shows a table query for tsWB.ECORev.

In the message box I see two records. When I run a BAQ on ECORev, I see none of the records that appear to be there in tsWB.

Does this sequence of events ring any bells for anyone? I am at a loss with this one. I have cleaned out ECORev and verified it with a BAQ. But when I run the messagebox to show me the table query for tsWB.ECORev, I still see two records.

Thanks!
Nate

Bumping this thread. I am still having an issue with records in the EcoRev tableset, but the records do not appear to be in the EcoRev table when I run a BAQ. This results in an error when I attempt to access a single row of the ecorev tableset. Does anyone have any ideas on this?
Thanks for your time!
Nate

From the message widget:
tsWB.EcoRev

GroupID

NATHAN
NATHAN
NATHAN

From the BAQ:

select 
	[ECORev].[GroupID] as [ECORev_GroupID]
from Erp.ECORev as ECORev
where (ECORev.GroupID = 'NATHAN')

Query returned 0 row(s).