During a upgrade from E9 to E10 the ClearDataSets() method isn’t working in an existing block of code. I don’t see this method in Reflector or the object explorer. When I try the existing code I get the following error;

I do see ClearData() in Reflector and tried that but get the following error:

I see that is the lower case version and looks like it is ported to the uppercase version but when it is in the base adapter how to I specify it more fully?

Any ideas on what I am doing wrong? I thought I saw posts where people were still using the ClearDataSets() method on the UD tables.


Yeah this issue is because VB is not case sensitive and the code in epicor is written in C# and implements clearData and ClearData… I’m not sure of a work-around but that’s your issue. Case sensitivity

Thanks, Jose. I tried clearData, too but it doesn’t want to play. Is the best solution to just convert it to C# at this time?


Yes I’d recommend that in general. VB is going to go away eventually so it will have to happen at some point. But yes going to C# will fix this issue.

Here’s the Microsoft Official Answer

Okay, thanks. I always write in C# but in this case they were looking to push it forward as-is, if possible.


1 Like