Creating Crystal Report Based from a BAQ

Wow, thanks Jose.  I was doing it all on the same computer, but yea somehow the C drives were different.  Maybe the C Drive Epicor was picking up was the C drive for the server, not my Computer?  I don't know though, as y'all can probably tell, I'm no computer expert.  I was able to find the correct C drive, which actually contained the win32_x86 folder, and I should be able to move forward now.  Thanks for the help everyone.

Hey Guys,


I'm currently trying to create a Crystal Report in Epicor based off of an already-made BAQ.  One of the first steps is: "Set the location of the Crystal Report Executable to the location of the CRW32.exe, under the Crystal Report XI R2 installation."  I can find the folder that contains crw32.exe in My Computer (win32_x86), but when I try to set the Crystal Report Executable in Epicor, I can't see the folder.  I've tried typing in the file location as well, but that also doesn't work.  Epicor Support has been little help in resolving this issue, and the guy I've been speaking with about it says he's never heard of anything like this happening before.


Has anyone had this problem before and found a solution?  By the way, I'm using Epicor 9 and have Crystal Reports 2008.  Any help appreciated.


Thanks,

Tyler Leonard





Tyler:


Do you have a master/service account (domain or workgroup) set up to automate processes throughout your E9 instance?  Your issue sounds like one I recently experienced:  on the Epicor and SQL servers, "Local System" was set to run most of the necessary tasks, but client installations outside of those areas could not resolve file locations, etc. because the services were using different (randomised) credentials.


If you are running E9 within the same domain, a single AD account can resolve this issue.  Otherwise, you need to create standalone accounts with matching credentials.



Hope this helps ...


Shaun W M Scott | SWMS



---In vantage@yahoogroups.com, <tyler123452@...> wrote :

Hey Guys,


I'm currently trying to create a Crystal Report in Epicor based off of an already-made BAQ.  One of the first steps is: "Set the location of the Crystal Report Executable to the location of the CRW32.exe, under the Crystal Report XI R2 installation."  I can find the folder that contains crw32.exe in My Computer (win32_x86), but when I try to set the Crystal Report Executable in Epicor, I can't see the folder.  I've tried typing in the file location as well, but that also doesn't work.  Epicor Support has been little help in resolving this issue, and the guy I've been speaking with about it says he's never heard of anything like this happening before.


Has anyone had this problem before and found a solution?  By the way, I'm using Epicor 9 and have Crystal Reports 2008.  Any help appreciated.


Thanks,

Tyler Leonard





Thanks for getting back to me Sean.  I don't have the expertise or permission to do what you just said, so I'm going to speak with one of my coworkers about your suggestion.  Will let you know if it works.

Geez:  kinda H8 that my profile was used, rather than my work addy (yay, Yahoo!) … there IS an article from E9 Support that should help.  I think I have the reference number(s) somewhere – let me know if you need those.

 

 

Regards …

 

Shaun W M Scott
Senior Systems Analyst - MRP


Scientific Drilling International

 


Information (including any attachments) contained in this electronic transmission is a PRIVILEGED AND CONFIDENTIAL COMMUNICATION. It is for the sole use of the sender and the entity named above. If you received this electronic transmission in error, you are required to immediately delete it in its entirety without making a copy. Further dissemination is absolutely prohibited. Thank you.   ­­  
<!-- #ygrps-yiv-1445297107 _filtered #ygrps-yiv-1445297107 {font-family:Wingdings; panose-1:5 0 0 0 0 0 0 0 0 0;} _filtered #ygrps-yiv-1445297107 {font-family:Wingdings; panose-1:5 0 0 0 0 0 0 0 0 0;} _filtered #ygrps-yiv-1445297107 {font-family:Calibri; panose-1:2 15 5 2 2 2 4 3 2 4;} _filtered #ygrps-yiv-1445297107 {font-family:Verdana; panose-1:2 11 6 4 3 5 4 4 2 4;} _filtered #ygrps-yiv-1445297107 {font-family:Consolas; panose-1:2 11 6 9 2 2 4 3 2 4;} #ygrps-yiv-1445297107 #ygrps-yiv-1445297107 p.ygrps-yiv-1445297107MsoNormal, #ygrps-yiv-1445297107 li.ygrps-yiv-1445297107MsoNormal, #ygrps-yiv-1445297107 div.ygrps-yiv-1445297107MsoNormal {margin:0in; margin-bottom:.0001pt; font-size:12.0pt; font-family:"Times New Roman", "serif";} #ygrps-yiv-1445297107 a:link, #ygrps-yiv-1445297107 span.ygrps-yiv-1445297107MsoHyperlink { color:blue; text-decoration:underline;} #ygrps-yiv-1445297107 a:visited, #ygrps-yiv-1445297107 span.ygrps-yiv-1445297107MsoHyperlinkFollowed { color:purple; text-decoration:underline;} #ygrps-yiv-1445297107 p {

margin-right:0in;

margin-left:0in;
font-size:12.0pt;
font-family:“Times New Roman”, “serif”;}
#ygrps-yiv-1445297107 code
{
font-family:“Courier New”;}
#ygrps-yiv-1445297107 pre
{

margin:0in;
margin-bottom:.0001pt;
font-size:10.0pt;
font-family:“Courier New”;}
#ygrps-yiv-1445297107 tt
{
font-family:“Courier New”;}
#ygrps-yiv-1445297107 span.ygrps-yiv-1445297107cat
{}
#ygrps-yiv-1445297107 span.ygrps-yiv-1445297107ct
{}
#ygrps-yiv-1445297107 span.ygrps-yiv-1445297107HTMLPreformattedChar
{

font-family:Consolas;}
#ygrps-yiv-1445297107 p.ygrps-yiv-1445297107attach, #ygrps-yiv-1445297107 li.ygrps-yiv-1445297107attach, #ygrps-yiv-1445297107 div.ygrps-yiv-1445297107attach
{

margin-right:0in;

margin-left:0in;
font-size:9.0pt;
font-family:“Arial”, “sans-serif”;}
#ygrps-yiv-1445297107 p.ygrps-yiv-1445297107bold, #ygrps-yiv-1445297107 li.ygrps-yiv-1445297107bold, #ygrps-yiv-1445297107 div.ygrps-yiv-1445297107bold
{

margin-right:0in;

margin-left:0in;
font-size:10.0pt;
font-family:“Arial”, “sans-serif”;
font-weight:bold;}
#ygrps-yiv-1445297107 p.ygrps-yiv-1445297107green, #ygrps-yiv-1445297107 li.ygrps-yiv-1445297107green, #ygrps-yiv-1445297107 div.ygrps-yiv-1445297107green
{

margin-right:0in;

margin-left:0in;
font-size:12.0pt;
font-family:“Times New Roman”, “serif”;
color:#628C2A;}
#ygrps-yiv-1445297107 p.ygrps-yiv-1445297107replbq, #ygrps-yiv-1445297107 li.ygrps-yiv-1445297107replbq, #ygrps-yiv-1445297107 div.ygrps-yiv-1445297107replbq
{
margin:3.0pt;
font-size:12.0pt;
font-family:“Times New Roman”, “serif”;}
#ygrps-yiv-1445297107 p.ygrps-yiv-1445297107ad, #ygrps-yiv-1445297107 li.ygrps-yiv-1445297107ad, #ygrps-yiv-1445297107 div.ygrps-yiv-1445297107ad
{

margin-right:0in;

margin-left:0in;
font-size:12.0pt;
font-family:“Times New Roman”, “serif”;}
#ygrps-yiv-1445297107 p.ygrps-yiv-1445297107underline, #ygrps-yiv-1445297107 li.ygrps-yiv-1445297107underline, #ygrps-yiv-1445297107 div.ygrps-yiv-1445297107underline
{

margin-right:0in;

margin-left:0in;
font-size:12.0pt;
font-family:“Times New Roman”, “serif”;}
#ygrps-yiv-1445297107 span.ygrps-yiv-1445297107yshortcuts
{}
#ygrps-yiv-1445297107 p.ygrps-yiv-1445297107ad1, #ygrps-yiv-1445297107 li.ygrps-yiv-1445297107ad1, #ygrps-yiv-1445297107 div.ygrps-yiv-1445297107ad1
{

margin-right:0in;

margin-left:0in;
font-size:12.0pt;
font-family:“Times New Roman”, “serif”;}
#ygrps-yiv-1445297107 p.ygrps-yiv-1445297107ad2, #ygrps-yiv-1445297107 li.ygrps-yiv-1445297107ad2, #ygrps-yiv-1445297107 div.ygrps-yiv-1445297107ad2
{

margin-right:0in;
margin-bottom:7.5pt;
margin-left:0in;
font-size:12.0pt;
font-family:“Times New Roman”, “serif”;}
#ygrps-yiv-1445297107 p.ygrps-yiv-1445297107underline1, #ygrps-yiv-1445297107 li.ygrps-yiv-1445297107underline1, #ygrps-yiv-1445297107 div.ygrps-yiv-1445297107underline1
{

margin-right:0in;

margin-left:0in;
font-size:12.0pt;
font-family:“Times New Roman”, “serif”;
text-decoration:underline;}
#ygrps-yiv-1445297107 span.ygrps-yiv-1445297107yshortcuts1
{
font-family:“Verdana”, “sans-serif”;
font-weight:bold;}
#ygrps-yiv-1445297107 span.ygrps-yiv-1445297107yshortcuts2
{
font-family:“Verdana”, “sans-serif”;
font-weight:normal;}
#ygrps-yiv-1445297107 span.ygrps-yiv-1445297107EmailStyle36
{
font-family:“Calibri”, “sans-serif”;
color:#1F497D;}
#ygrps-yiv-1445297107 .ygrps-yiv-1445297107MsoChpDefault
{
font-size:10.0pt;}
_filtered #ygrps-yiv-1445297107 {
margin:1.0in 1.0in 1.0in 1.0in;}
#ygrps-yiv-1445297107 div.ygrps-yiv-1445297107WordSection1
{}
#ygrps-yiv-1445297107
_filtered #ygrps-yiv-1445297107 {
}
_filtered #ygrps-yiv-1445297107 {

font-family:Symbol;}
_filtered #ygrps-yiv-1445297107 {

font-family:“Courier New”;
}
_filtered #ygrps-yiv-1445297107 {

font-family:Wingdings;}
_filtered #ygrps-yiv-1445297107 {

font-family:Wingdings;}
_filtered #ygrps-yiv-1445297107 {

font-family:Wingdings;}
_filtered #ygrps-yiv-1445297107 {

font-family:Wingdings;}
_filtered #ygrps-yiv-1445297107 {

font-family:Wingdings;}
_filtered #ygrps-yiv-1445297107 {

font-family:Wingdings;}
_filtered #ygrps-yiv-1445297107 {

font-family:Wingdings;}
#ygrps-yiv-1445297107 ol
{margin-bottom:0in;}
#ygrps-yiv-1445297107 ul
{margin-bottom:0in;}
–>

When I tried to do my first one I had an issue with the location also. It was a while ago, but I am not sure if my issue was the same as yours. Mine had to do with the default location that was set in the SystemTaskAgent in Epicor / system Agent. Ours had the incorrect location. Once that was fixed I was able to follow the Epicor  directions.

Yea if you can find that reference number that would be great.  Thanks.

Do you have Crystal Developer installed on your computer?   You need to have Crystal  installed locally on your computer you’re developing the report from.  If you do have it installed on your local machine then it should be somewhere around :  C:\Program Files (x86)\Business Objects\BusinessObjects Enterprise 12.0\win32_x86\

 

 

 

From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com]
Sent: Wednesday, November 5, 2014 11:31 AM
To: vantage@yahoogroups.com
Subject: [Vantage] Creating Crystal Report Based from a BAQ

 

 

Hey Guys,

 

I'm currently trying to create a Crystal Report in Epicor based off of an already-made BAQ.  One of the first steps is: "Set the location of the Crystal Report Executable to the location of the CRW32.exe, under the Crystal Report XI R2 installation."  I can find the folder that contains crw32.exe in My Computer (win32_x86), but when I try to set the Crystal Report Executable in Epicor, I can't see the folder.  I've tried typing in the file location as well, but that also doesn't work.  Epicor Support has been little help in resolving this issue, and the guy I've been speaking with about it says he's never heard of anything like this happening before.

 

Has anyone had this problem before and found a solution?  By the way, I'm using Epicor 9 and have Crystal Reports 2008.  Any help appreciated.

 

Thanks,

Tyler Leonard

 

 

 

 

Jose,

I do have Crystal Reports installed locally and was able to find the file location you were talking about.  The problem is that while I can find that location in My Computer, I can't find it in Epicor.  It seems like you can't paste images or attach documents here so I'm attaching a link to a google doc that shows my dilemma.

https://docs.google.com/document/d/17p5UJVBnTFPyF-e5OxlnxY3LVayTTG0imTwRDtrk41U/edit

<!-- #ygrps-yiv-2106916922 _filtered #ygrps-yiv-2106916922 {font-family:Wingdings; panose-1:5 0 0 0 0 0 0 0 0 0;} _filtered #ygrps-yiv-2106916922 {font-family:Wingdings; panose-1:5 0 0 0 0 0 0 0 0 0;} _filtered #ygrps-yiv-2106916922 {font-family:Calibri; panose-1:2 15 5 2 2 2 4 3 2 4;} _filtered #ygrps-yiv-2106916922 {font-family:Verdana; panose-1:2 11 6 4 3 5 4 4 2 4;} _filtered #ygrps-yiv-2106916922 {font-family:Consolas; panose-1:2 11 6 9 2 2 4 3 2 4;} #ygrps-yiv-2106916922 #ygrps-yiv-2106916922 p.ygrps-yiv-2106916922MsoNormal, #ygrps-yiv-2106916922 li.ygrps-yiv-2106916922MsoNormal, #ygrps-yiv-2106916922 div.ygrps-yiv-2106916922MsoNormal {margin:0in; margin-bottom:.0001pt; font-size:12.0pt; font-family:"Times New Roman", "serif";} #ygrps-yiv-2106916922 a:link, #ygrps-yiv-2106916922 span.ygrps-yiv-2106916922MsoHyperlink { color:blue; text-decoration:underline;} #ygrps-yiv-2106916922 a:visited, #ygrps-yiv-2106916922 span.ygrps-yiv-2106916922MsoHyperlinkFollowed { color:purple; text-decoration:underline;} #ygrps-yiv-2106916922 p {

margin-right:0in;

margin-left:0in;
font-size:12.0pt;
font-family:“Times New Roman”, “serif”;}
#ygrps-yiv-2106916922 code
{
font-family:“Courier New”;}
#ygrps-yiv-2106916922 pre
{

margin:0in;
margin-bottom:.0001pt;
font-size:10.0pt;
font-family:“Courier New”;}
#ygrps-yiv-2106916922 tt
{
font-family:“Courier New”;}
#ygrps-yiv-2106916922 span.ygrps-yiv-2106916922cat
{}
#ygrps-yiv-2106916922 span.ygrps-yiv-2106916922ct
{}
#ygrps-yiv-2106916922 span.ygrps-yiv-2106916922HTMLPreformattedChar
{

font-family:Consolas;}
#ygrps-yiv-2106916922 p.ygrps-yiv-2106916922attach, #ygrps-yiv-2106916922 li.ygrps-yiv-2106916922attach, #ygrps-yiv-2106916922 div.ygrps-yiv-2106916922attach
{

margin-right:0in;

margin-left:0in;
font-size:9.0pt;
font-family:“Arial”, “sans-serif”;}
#ygrps-yiv-2106916922 p.ygrps-yiv-2106916922bold, #ygrps-yiv-2106916922 li.ygrps-yiv-2106916922bold, #ygrps-yiv-2106916922 div.ygrps-yiv-2106916922bold
{

margin-right:0in;

margin-left:0in;
font-size:10.0pt;
font-family:“Arial”, “sans-serif”;
font-weight:bold;}
#ygrps-yiv-2106916922 p.ygrps-yiv-2106916922green, #ygrps-yiv-2106916922 li.ygrps-yiv-2106916922green, #ygrps-yiv-2106916922 div.ygrps-yiv-2106916922green
{

margin-right:0in;

margin-left:0in;
font-size:12.0pt;
font-family:“Times New Roman”, “serif”;
color:#628C2A;}
#ygrps-yiv-2106916922 p.ygrps-yiv-2106916922replbq, #ygrps-yiv-2106916922 li.ygrps-yiv-2106916922replbq, #ygrps-yiv-2106916922 div.ygrps-yiv-2106916922replbq
{
margin:3.0pt;
font-size:12.0pt;
font-family:“Times New Roman”, “serif”;}
#ygrps-yiv-2106916922 p.ygrps-yiv-2106916922ad, #ygrps-yiv-2106916922 li.ygrps-yiv-2106916922ad, #ygrps-yiv-2106916922 div.ygrps-yiv-2106916922ad
{

margin-right:0in;

margin-left:0in;
font-size:12.0pt;
font-family:“Times New Roman”, “serif”;}
#ygrps-yiv-2106916922 p.ygrps-yiv-2106916922underline, #ygrps-yiv-2106916922 li.ygrps-yiv-2106916922underline, #ygrps-yiv-2106916922 div.ygrps-yiv-2106916922underline
{

margin-right:0in;

margin-left:0in;
font-size:12.0pt;
font-family:“Times New Roman”, “serif”;}
#ygrps-yiv-2106916922 span.ygrps-yiv-2106916922yshortcuts
{}
#ygrps-yiv-2106916922 p.ygrps-yiv-2106916922ad1, #ygrps-yiv-2106916922 li.ygrps-yiv-2106916922ad1, #ygrps-yiv-2106916922 div.ygrps-yiv-2106916922ad1
{

margin-right:0in;

margin-left:0in;
font-size:12.0pt;
font-family:“Times New Roman”, “serif”;}
#ygrps-yiv-2106916922 p.ygrps-yiv-2106916922ad2, #ygrps-yiv-2106916922 li.ygrps-yiv-2106916922ad2, #ygrps-yiv-2106916922 div.ygrps-yiv-2106916922ad2
{

margin-right:0in;
margin-bottom:7.5pt;
margin-left:0in;
font-size:12.0pt;
font-family:“Times New Roman”, “serif”;}
#ygrps-yiv-2106916922 p.ygrps-yiv-2106916922underline1, #ygrps-yiv-2106916922 li.ygrps-yiv-2106916922underline1, #ygrps-yiv-2106916922 div.ygrps-yiv-2106916922underline1
{

margin-right:0in;

margin-left:0in;
font-size:12.0pt;
font-family:“Times New Roman”, “serif”;
text-decoration:underline;}
#ygrps-yiv-2106916922 span.ygrps-yiv-2106916922yshortcuts1
{
font-family:“Verdana”, “sans-serif”;
font-weight:bold;}
#ygrps-yiv-2106916922 span.ygrps-yiv-2106916922yshortcuts2
{
font-family:“Verdana”, “sans-serif”;
font-weight:normal;}
#ygrps-yiv-2106916922 span.ygrps-yiv-2106916922EmailStyle36
{
font-family:“Calibri”, “sans-serif”;
color:#1F497D;}
#ygrps-yiv-2106916922 .ygrps-yiv-2106916922MsoChpDefault
{
font-size:10.0pt;}
_filtered #ygrps-yiv-2106916922 {
margin:1.0in 1.0in 1.0in 1.0in;}
#ygrps-yiv-2106916922 div.ygrps-yiv-2106916922WordSection1
{}
#ygrps-yiv-2106916922
_filtered #ygrps-yiv-2106916922 {
}
_filtered #ygrps-yiv-2106916922 {

font-family:Symbol;}
_filtered #ygrps-yiv-2106916922 {

font-family:“Courier New”;
}
_filtered #ygrps-yiv-2106916922 {

font-family:Wingdings;}
_filtered #ygrps-yiv-2106916922 {

font-family:Wingdings;}
_filtered #ygrps-yiv-2106916922 {

font-family:Wingdings;}
_filtered #ygrps-yiv-2106916922 {

font-family:Wingdings;}
_filtered #ygrps-yiv-2106916922 {

font-family:Wingdings;}
_filtered #ygrps-yiv-2106916922 {

font-family:Wingdings;}
_filtered #ygrps-yiv-2106916922 {

font-family:Wingdings;}
#ygrps-yiv-2106916922 ol
{margin-bottom:0in;}
#ygrps-yiv-2106916922 ul
{margin-bottom:0in;}
–>

Does it allow you to copy and paste the correct location in even if you can’t search to find it?

 

I don't launch Crystal from the BAQ Report Designer... just preference I guess. Click Actions > Deploy BAQ Report and it will save the *.rpt file to your designated location (\\server\epicor905\Server\reports\CustomReports for instance). Load Crystal from outside Epicor and drag and drop the *.rpt file from Windows Explorer into Crystal. You can modify and save the rpt right there. Crystal doesn't have to be launched from Epicor.
No, tried that already and it didn't work.

I think I  see your problem… From your screenshots and the way things look it seems like you’re doing this on 2 different computers?

 

 

I say that because the C drives have different names. If you want to use the functionality of the BAQ report  screen   to go to Actions> Design  etc then Epicor and Crystal have to be on  the same computer.  If you’re running Epicor on a different computer and have Crystal on another that won’t work

 

That’s not to say this is the only way to develop a BAQ report but if  you’re just starting out it might be a good option.

 

 

 

 

From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com]
Sent: Thursday, November 6, 2014 9:50 AM
To: vantage@yahoogroups.com
Subject: [Vantage] Re: Creating Crystal Report Based from a BAQ

 

 

Jose,

 

I do have Crystal Reports installed locally and was able to find the file location you were talking about.  The problem is that while I can find that location in My Computer, I can't find it in Epicor.  It seems like you can't paste images or attach documents here so I'm attaching a link to a google doc that shows my dilemma.