Crystal Reports - Add Table Help

This probably had more to do with the join types. Generally things work better using left outer joins (right click on the link line between the tables and change the join type). Turning off smart linking is not a bad practice either.



From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf Of Keith Walter
Sent: Thursday, March 25, 2010 2:07 PM
To: vantage@yahoogroups.com
Subject: Re: [Vantage] Re: Crystal Reports - Add Table Help





I found the problem: it was in crystal reports settings (File -> Options), a setting called "smart linking". Apparently I was doing everything right, this flag was breaking the links somhow. I turned it off and it works!

Keith Walter
Vantage Coordinator
Norgren Automation Solutions, Saline Division
keith.walter@... <mailto:keith.walter%40norgrenauto.com>

________________________________
From: howco22 <agortman@... <mailto:agortman%40howecorp.com> >
To: vantage@yahoogroups.com <mailto:vantage%40yahoogroups.com>
Sent: Thu, March 25, 2010 9:10:26 AM
Subject: [Vantage] Re: Crystal Reports - Add Table Help


The RDD is the Report Data Definition.

I had a hard time getting the Tracking number on the form. I added the shiphead table to the RDD, then made a relationship in the RDD, in crystal I did not link the table.
I made a sub report for the tracking number, then added that subreport to the ARForm.

--- In vantage@yahoogroups .com, Keith Walter <keithfwalter@ ...> wrote:
>
> IÂ don't think so... what is the RDD?
> Â
> Keith Walter
> Vantage Coordinator
> Norgren Automation Solutions, Saline Division
> keith.walter@ ...
>
>
>
>
> ____________ _________ _________ __
> From: howco22 <agortman@.. .>
> To: vantage@yahoogroups .com
> Sent: Wed, March 24, 2010 5:10:21 PM
> Subject: [Vantage] Re: Crystal Reports - Add Table Help
>
> Â
> Did you add any relationships in the RDD?
>
> --- In vantage@yahoogroups .com, Keith Walter <keithfwalter@ ...> wrote:
> >
> > I am adding a table to the ARForm (Invoice). I am a newby at Crystal and could use some guidance if anyone is willing to help.
> >
> > I want to add the SalesRep table, so that I can get the salesperson email on this report. I created a new ReportDataDef, add the SalesRep table, Created a Relationship from Customer to SalesRep on Company and SalesRepCode. I also added the EmailAddress and SalesRepCode fields to the Description Fields tab (not sure if I needed to do this) I then made sure that the SalesRep table did not have the SalesRepCode and SalesRepEmail fields excluded. That should be good, right?
> >
> > I then did the RerportStyle thing, referancing my new DataDef. and generated a report xml file.
> >
> > I then, in crystal, went the SetDatabaseLocation process, added an new ADO.NET (XML) connection to the xml file i just created. I then went into the DataBase Expert, and moved the new table over to the right pane (selected tables), and set the relationships in the link tab (Customer.Company -> SalesRep.Company & Customer.SalesRepCo de -> SalesRep.SalesRepCo de).
> >
> > Now my problem:
> >
> > When I try to preview the report in crystal it gives me these errors:
> > 1) Failed to retrieve dataset from database (i click OK and:)
> > 2) Database Connection Error: 'If tables are already linked then the join type cannot change.'
> >
> > What am I missing?
> >
> > Thanks,
> > Â
> > Keith Walter
> > Vantage Coordinator
> > Norgren Automation Solutions, Saline Division
> > keith.walter@ ...
> >
> > ____________ _________ _________ _________ _________ __
> > Do You Yahoo!?
> > Tired of spam? Yahoo! Mail has the best spam protection around
> > http://mail. yahoo.com
> >
> > [Non-text portions of this message have been removed]
> >
>
>
>
>
>
>
>
> [Non-text portions of this message have been removed]
>

[Non-text portions of this message have been removed]





[Non-text portions of this message have been removed]
I am adding a table to the ARForm (Invoice). I am a newby at Crystal and could use some guidance if anyone is willing to help.

I want to add the SalesRep table, so that I can get the salesperson email on this report. I created a new ReportDataDef, add the SalesRep table, Created a Relationship from Customer to SalesRep on Company and SalesRepCode. I also added the EmailAddress and SalesRepCode fields to the Description Fields tab (not sure if I needed to do this) I then made sure that the SalesRep table did not have the SalesRepCode and SalesRepEmail fields excluded. That should be good, right?

I then did the RerportStyle thing, referancing my new DataDef. and generated a report xml file.

I then, in crystal, went the SetDatabaseLocation process, added an new ADO.NET (XML) connection to the xml file i just created. I then went into the DataBase Expert, and moved the new table over to the right pane (selected tables), and set the relationships in the link tab (Customer.Company -> SalesRep.Company & Customer.SalesRepCode -> SalesRep.SalesRepCode).

Now my problem:

When I try to preview the report in crystal it gives me these errors:
1) Failed to retrieve dataset from database (i click OK and:)
2) Database Connection Error: 'If tables are already linked then the join type cannot change.'

What am I missing?

Thanks,
Â
Keith Walter
Vantage Coordinator
Norgren Automation Solutions, Saline Division
keith.walter@...

__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

[Non-text portions of this message have been removed]
Did you add any relationships in the RDD?


--- In vantage@yahoogroups.com, Keith Walter <keithfwalter@...> wrote:
>
> I am adding a table to the ARForm (Invoice). I am a newby at Crystal and could use some guidance if anyone is willing to help.
>
> I want to add the SalesRep table, so that I can get the salesperson email on this report. I created a new ReportDataDef, add the SalesRep table, Created a Relationship from Customer to SalesRep on Company and SalesRepCode. I also added the EmailAddress and SalesRepCode fields to the Description Fields tab (not sure if I needed to do this) I then made sure that the SalesRep table did not have the SalesRepCode and SalesRepEmail fields excluded. That should be good, right?
>
> I then did the RerportStyle thing, referancing my new DataDef. and generated a report xml file.
>
> I then, in crystal, went the SetDatabaseLocation process, added an new ADO.NET (XML) connection to the xml file i just created. I then went into the DataBase Expert, and moved the new table over to the right pane (selected tables), and set the relationships in the link tab (Customer.Company -> SalesRep.Company & Customer.SalesRepCode -> SalesRep.SalesRepCode).
>
> Now my problem:
>
> When I try to preview the report in crystal it gives me these errors:
> 1) Failed to retrieve dataset from database (i click OK and:)
> 2) Database Connection Error: 'If tables are already linked then the join type cannot change.'
>
> What am I missing?
>
> Thanks,
> Â
> Keith Walter
> Vantage Coordinator
> Norgren Automation Solutions, Saline Division
> keith.walter@...
>
> __________________________________________________
> Do You Yahoo!?
> Tired of spam? Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com
>
> [Non-text portions of this message have been removed]
>
IÂ don't think so... what is the RDD?
Â
Keith Walter
Vantage Coordinator
Norgren Automation Solutions, Saline Division
keith.walter@...




________________________________
From: howco22 <agortman@...>
To: vantage@yahoogroups.com
Sent: Wed, March 24, 2010 5:10:21 PM
Subject: [Vantage] Re: Crystal Reports - Add Table Help

Â
Did you add any relationships in the RDD?

--- In vantage@yahoogroups .com, Keith Walter <keithfwalter@ ...> wrote:
>
> I am adding a table to the ARForm (Invoice). I am a newby at Crystal and could use some guidance if anyone is willing to help.
>
> I want to add the SalesRep table, so that I can get the salesperson email on this report. I created a new ReportDataDef, add the SalesRep table, Created a Relationship from Customer to SalesRep on Company and SalesRepCode. I also added the EmailAddress and SalesRepCode fields to the Description Fields tab (not sure if I needed to do this) I then made sure that the SalesRep table did not have the SalesRepCode and SalesRepEmail fields excluded. That should be good, right?
>
> I then did the RerportStyle thing, referancing my new DataDef. and generated a report xml file.
>
> I then, in crystal, went the SetDatabaseLocation process, added an new ADO.NET (XML) connection to the xml file i just created. I then went into the DataBase Expert, and moved the new table over to the right pane (selected tables), and set the relationships in the link tab (Customer.Company -> SalesRep.Company & Customer.SalesRepCo de -> SalesRep.SalesRepCo de).
>
> Now my problem:
>
> When I try to preview the report in crystal it gives me these errors:
> 1) Failed to retrieve dataset from database (i click OK and:)
> 2) Database Connection Error: 'If tables are already linked then the join type cannot change.'
>
> What am I missing?
>
> Thanks,
> Â
> Keith Walter
> Vantage Coordinator
> Norgren Automation Solutions, Saline Division
> keith.walter@ ...
>
> ____________ _________ _________ _________ _________ __
> Do You Yahoo!?
> Tired of spam? Yahoo! Mail has the best spam protection around
> http://mail. yahoo.com
>
> [Non-text portions of this message have been removed]
>







[Non-text portions of this message have been removed]
The RDD is the Report Data Definition.

I had a hard time getting the Tracking number on the form. I added the shiphead table to the RDD, then made a relationship in the RDD, in crystal I did not link the table.
I made a sub report for the tracking number, then added that subreport to the ARForm.


--- In vantage@yahoogroups.com, Keith Walter <keithfwalter@...> wrote:
>
> I don't think so... what is the RDD?
> ÂÂ
> Keith Walter
> Vantage Coordinator
> Norgren Automation Solutions, Saline Division
> keith.walter@...
>
>
>
>
> ________________________________
> From: howco22 <agortman@...>
> To: vantage@yahoogroups.com
> Sent: Wed, March 24, 2010 5:10:21 PM
> Subject: [Vantage] Re: Crystal Reports - Add Table Help
>
> ÂÂ
> Did you add any relationships in the RDD?
>
> --- In vantage@yahoogroups .com, Keith Walter <keithfwalter@ ...> wrote:
> >
> > I am adding a table to the ARForm (Invoice). I am a newby at Crystal and could use some guidance if anyone is willing to help.
> >
> > I want to add the SalesRep table, so that I can get the salesperson email on this report. I created a new ReportDataDef, add the SalesRep table, Created a Relationship from Customer to SalesRep on Company and SalesRepCode. I also added the EmailAddress and SalesRepCode fields to the Description Fields tab (not sure if I needed to do this) I then made sure that the SalesRep table did not have the SalesRepCode and SalesRepEmail fields excluded. That should be good, right?
> >
> > I then did the RerportStyle thing, referancing my new DataDef. and generated a report xml file.
> >
> > I then, in crystal, went the SetDatabaseLocation process, added an new ADO.NET (XML) connection to the xml file i just created. I then went into the DataBase Expert, and moved the new table over to the right pane (selected tables), and set the relationships in the link tab (Customer.Company -> SalesRep.Company & Customer.SalesRepCo de -> SalesRep.SalesRepCo de).
> >
> > Now my problem:
> >
> > When I try to preview the report in crystal it gives me these errors:
> > 1) Failed to retrieve dataset from database (i click OK and:)
> > 2) Database Connection Error: 'If tables are already linked then the join type cannot change.'
> >
> > What am I missing?
> >
> > Thanks,
> > ÂÂ
> > Keith Walter
> > Vantage Coordinator
> > Norgren Automation Solutions, Saline Division
> > keith.walter@ ...
> >
> > ____________ _________ _________ _________ _________ __
> > Do You Yahoo!?
> > Tired of spam? Yahoo! Mail has the best spam protection around
> > http://mail. yahoo.com
> >
> > [Non-text portions of this message have been removed]
> >
>
>
>
>
>
>
>
> [Non-text portions of this message have been removed]
>
I found the problem: it was in crystal reports settings (File -> Options), a setting called "smart linking". Apparently I was doing everything right, this flag was breaking the links somhow. I turned it off and it works!
Â
Keith Walter
Vantage Coordinator
Norgren Automation Solutions, Saline Division
keith.walter@...




________________________________
From: howco22 <agortman@...>
To: vantage@yahoogroups.com
Sent: Thu, March 25, 2010 9:10:26 AM
Subject: [Vantage] Re: Crystal Reports - Add Table Help

Â
The RDD is the Report Data Definition.

I had a hard time getting the Tracking number on the form. I added the shiphead table to the RDD, then made a relationship in the RDD, in crystal I did not link the table.
I made a sub report for the tracking number, then added that subreport to the ARForm.

--- In vantage@yahoogroups .com, Keith Walter <keithfwalter@ ...> wrote:
>
> I don't think so... what is the RDD?
> ÂÂ
> Keith Walter
> Vantage Coordinator
> Norgren Automation Solutions, Saline Division
> keith.walter@ ...
>
>
>
>
> ____________ _________ _________ __
> From: howco22 <agortman@.. .>
> To: vantage@yahoogroups .com
> Sent: Wed, March 24, 2010 5:10:21 PM
> Subject: [Vantage] Re: Crystal Reports - Add Table Help
>
> ÂÂ
> Did you add any relationships in the RDD?
>
> --- In vantage@yahoogroups .com, Keith Walter <keithfwalter@ ...> wrote:
> >
> > I am adding a table to the ARForm (Invoice). I am a newby at Crystal and could use some guidance if anyone is willing to help.
> >
> > I want to add the SalesRep table, so that I can get the salesperson email on this report. I created a new ReportDataDef, add the SalesRep table, Created a Relationship from Customer to SalesRep on Company and SalesRepCode. I also added the EmailAddress and SalesRepCode fields to the Description Fields tab (not sure if I needed to do this) I then made sure that the SalesRep table did not have the SalesRepCode and SalesRepEmail fields excluded. That should be good, right?
> >
> > I then did the RerportStyle thing, referancing my new DataDef. and generated a report xml file.
> >
> > I then, in crystal, went the SetDatabaseLocation process, added an new ADO.NET (XML) connection to the xml file i just created. I then went into the DataBase Expert, and moved the new table over to the right pane (selected tables), and set the relationships in the link tab (Customer.Company -> SalesRep.Company & Customer.SalesRepCo de -> SalesRep.SalesRepCo de).
> >
> > Now my problem:
> >
> > When I try to preview the report in crystal it gives me these errors:
> > 1) Failed to retrieve dataset from database (i click OK and:)
> > 2) Database Connection Error: 'If tables are already linked then the join type cannot change.'
> >
> > What am I missing?
> >
> > Thanks,
> > ÂÂ
> > Keith Walter
> > Vantage Coordinator
> > Norgren Automation Solutions, Saline Division
> > keith.walter@ ...
> >
> > ____________ _________ _________ _________ _________ __
> > Do You Yahoo!?
> > Tired of spam? Yahoo! Mail has the best spam protection around
> > http://mail. yahoo.com
> >
> > [Non-text portions of this message have been removed]
> >
>
>
>
>
>
>
>
> [Non-text portions of this message have been removed]
>







[Non-text portions of this message have been removed]