Crystal Runtime, Calendar control, Citrix

Tony, this is an IE thing.  Can't recall how I fixed it in the past, but try loosening up IE's defenses a bit. 

 

From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com]
Sent: Thursday, June 05, 2014 5:34 PM
To: vantage@yahoogroups.com
Subject: [Vantage] Crystal Runtime, Calendar control, Citrix

 

 

We're on Vantage 8.03.409a.

 

Recently set up a new Citrix server to add to the existing ones.

Installed the Vantage client, and then the crystal runtime (Crystal Reports XI R2 .Net 3.0 Runtime SP5.msi) that we downloaded from Epicweb. 

The Crystal runtime was installed by an admin, going through the control panel, and in TS install mode.

 

However on this new Citrix server, any custom Crystal report that has a parameter form containing the Calendar control - the calendar control will not work when you click the icon. 

But, *I* can run custom crystal reports that have a calendar control on the parameter form just fine. The difference is that I am a local admin, among other groups, on that Citrix server.

 

I've seen this problem before, it was at least 3-4 years since we had this problem, and at the time installing a different CR runtime fixed it. I believe installing Crystal runtime SP 3 fixed it, but don't quote me.

Any user who is not a local admin, the calendar control will not work. 

 

Any suggestions to try?

 

Thanks.

 

 

We're on Vantage 8.03.409a.

Recently set up a new Citrix server to add to the existing ones.
Installed the Vantage client, and then the crystal runtime (Crystal Reports XI R2 .Net 3.0 Runtime SP5.msi) that we downloaded from Epicweb. 
The Crystal runtime was installed by an admin, going through the control panel, and in TS install mode.

However on this new Citrix server, any custom Crystal report that has a parameter form containing the Calendar control - the calendar control will not work when you click the icon. 
But, *I* can run custom crystal reports that have a calendar control on the parameter form just fine. The difference is that I am a local admin, among other groups, on that Citrix server.

I've seen this problem before, it was at least 3-4 years since we had this problem, and at the time installing a different CR runtime fixed it. I believe installing Crystal runtime SP 3 fixed it, but don't quote me.
Any user who is not a local admin, the calendar control will not work. 

Any suggestions to try?

Thanks.

 
#ygrps-yiv-1443457239 P.ygrps-yiv-1443457239ce387540-7764-462c-979a-97379ccda45c { MARGIN:0cm 0cm 0pt;} #ygrps-yiv-1443457239 LI.ygrps-yiv-1443457239ce387540-7764-462c-979a-97379ccda45c { MARGIN:0cm 0cm 0pt;} #ygrps-yiv-1443457239 DIV.ygrps-yiv-1443457239ce387540-7764-462c-979a-97379ccda45c { MARGIN:0cm 0cm 0pt;} #ygrps-yiv-1443457239 TABLE.ygrps-yiv-1443457239ce387540-7764-462c-979a-97379ccda45cTable { MARGIN:0cm 0cm 0pt;} #ygrps-yiv-1443457239 DIV.ygrps-yiv-1443457239Section1 { }

Tony,

 

I don’t have the exact details to hand but I think this relates to restrictions in internet explorer that you need to amend for the non admin users.

 

 

From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com]
Sent: 05 June 2014 22:34
To: vantage@yahoogroups.com
Subject: [Vantage] Crystal Runtime, Calendar control, Citrix

 

 

We're on Vantage 8.03.409a.

 

Recently set up a new Citrix server to add to the existing ones.

Installed the Vantage client, and then the crystal runtime (Crystal Reports XI R2 .Net 3.0 Runtime SP5.msi) that we downloaded from Epicweb. 

The Crystal runtime was installed by an admin, going through the control panel, and in TS install mode.

 

However on this new Citrix server, any custom Crystal report that has a parameter form containing the Calendar control - the calendar control will not work when you click the icon. 

But, *I* can run custom crystal reports that have a calendar control on the parameter form just fine. The difference is that I am a local admin, among other groups, on that Citrix server.

 

I've seen this problem before, it was at least 3-4 years since we had this problem, and at the time installing a different CR runtime fixed it. I believe installing Crystal runtime SP 3 fixed it, but don't quote me.

Any user who is not a local admin, the calendar control will not work. 

 

Any suggestions to try?

 

Thanks.

 

 



Stephen Edginton (Beng) | Solutions & Technical Director

Mobile:  +44 7734 858415
Main:  +44 (0) 121 314 1170
Web:  www.dotnetit.co.uk

Dot Net IT Limited, One St Kenelm Court, Steel Park Road, Halesowen, B62 8HD, United Kingdom.

DotNetIT

Epicor Platinum Partner

Epicor Alliance Partner