Customer part delete DMT skipping rows

We are cleaning up old records in our customer part cross reference table, and the delete DMT skips every other row every time I process. The DMT error log provides an error of “record not found” for every other row, but I can re-run the error file with no change, and exactly every other row will be deleted. Has anyone experienced this?

Can you provide an example of the file you are using? I’m interested in the columns and their sequence.

Trying with customer number.xlsx (9.4 KB)
Thank you for asking! This is my file.

It might not be your problem, but you should only use CustID and not the customer number.

DMT will look the number for the specified ID.

You should also set your columns in the same sequence as the required fields indicates, in this case, Company, CustNumCustID, PartNum and then XPartNum.

I would also recommend converting your xslx to a csv file type when running in DMT. Although it will accept the other I found a similar issue when not running as csv.

That’s a bummer but something to watch out for. I usually run in .xlsx because I’ve had nightmares opening .csv files where leading zeroes disappear from part numbers like 0028473

I am so grateful for the advice! I tried the csv, and restructuring columns, and still only getting every other row. We are on 2022.1.6, and it is buggy. I’ve got a ticket opened with Epicor, I’ll come back if they have any insight!

if you’re up for a work around, run the XLS file. Then delete row 1, and run it again.

The first run would process rows 1, 3, 5, … The second time the original row 2 is now row 1, original row 4 is now row 3, etc…

I wonder what would happen if you had a file with three identical rows. Deletes the first, skips the second, then errors out on the third?

Do you have any BPMs related to customer part cross reference?

This is why I use Excel 97-2003 (.xls) format. It has consistently worked. CSV just has too many issues with formatting.