Customization Weird Cache Breaking Mtl Queue Formatting

While attempting to reformat the datagrid on Material Request Queue, I ran into a strange formatting error that I haven’t been able to figure out. Whenever the form is opened for the first time after a cache clear it looks perfect and functions fine. On every subsequent opening of the form the UltraGrid is expanded and obscures essential buttons located below it. Scroll bars also disappear. Another piece to this puzzle is that this only happens outside of Developer Mode. With Dev Mode on the form can be opened and closed infinite times without issue. The form can be “fixed” if the cache is deleted and then the form is reopened, but again this only works for the first opening.

This is extra confusing because the nature of the changes made to the form have little to do with the actual visual position or formatting of the form. All that is being done is reordering some fields and adding UD fields to the data grid along with some material tag data format modifications.

Any insight on this topic will be extremely helpful, as I have been unable to find someone with a similar issue anywhere.

Below I have attached a picture of Material Request Queue on the first open after a cache clear and then a picture of Material Request Queue after closing the form and immediately reopening it.


I had the same issue while formatting our Mtl Queue layout. I had to turn off all anchoring down to the grid, blow the form up to full screen, set the layout how I wanted, turn anchoring back on, shrink the form to preferred size. Then save the customization, close the customization screen, save the layouts while in dev mode, close the form, clear cache then test outside of dev mode.

It wouldn’t stick for me until I saved the layouts, after formatting the form, while still in dev mode. Not sure why.

Below are pictures of the sizes and anchoring I set, from the grid up.

My end result looks like this:

Hope this helps.

Thank you for the reply! I will try this out and see what happens. Glad to know I wasn’t the only one with this issue.