Dashboard Tracker - MATCHES

All, just moved to 10.1.500.17 from 10.0.700.4, when typing a string into a tracker field that had a matches filter it would allow them to return results without the use of wild cards as shown below (almost acted like a contains)

now they must either enter an exact match or use wild cards… so the million dollar question is, which version is/was working correctly or ‘as designed’?

I am having the same issue with 10.1.500.11. The “matches” doesn’t function at all.

I want to say that I was experiencing that “issue” as well - or seemingly different behavior at least - and it was on a dashboard where the “tracker” was a customized one, not just a simple generated one. I believe we were able to resolve it by deleting the text field in question and re-creating it, setting it up as a MATCHES still. Then I think it was better behaved. Although I still think they changed it back to where you have to explicitly put in * for wildcards.

thanks! Documentation i have found indicates that you should be using wild cards as it implies an exact match. However observed behavior in 10.0 said otherwise. So if it doesn’t work that way anymore i can understand it. In this case not working seemed to be a bigger benefit ironically… as a work around i grammatically added the wild card in on validate for those couple fields.

So it’s working like a SQL like clause now?

Correct, SQL LIKE

1 Like