I use the UD08 with 3 customs fields:

  • CountryNum_c
  • ZipStartRange_c
  • ZipEndRange_c

I create a BAQ to list all 3 fields plus the country description. I create a new dashboard with a TrackerView based on my BAQ. In my trackview, I placed a filter on the country description and on the ZipStartRange.

I have 2 problems, the first one is when I select a country, the trackerview try to filter the country desciption by the country num.

The 2nd problem I have is I want to enter a zip code and and return the records where my zip code fall between the ZipStartRange_c and the ZipEndRange_c.


I have a dashboard with a Tracker

For the first issue, are you saying that the filter will provide the correct records when you type in the description or that you get the correct records when you type in the Number? It should be whatever field you are returning, so if you want it to be the description then you’ll have to join to the description table in the BAQ and use that field for the filter.
For the second issue, you create the first filter with lower range and greater that equal need to customize the tracker view and create the second control that is the upper end of the range and less than equal.
Note that it may be best to add all the filters through customize tracker since I’ve found issues with formatting when mixing adding through the customize and not.

Hope this helps.

It appears that you’re trying to duplicate Territory Boundaries.
Would you like to use a Territory?

Hi Mark,

It’s a little bit more complicated than that, that’s why I didn’t do it this way loll



Hi Andrew,

No, the filter doesn’t work at all :frowning: When I look into the Epicor Tracing Log, I saw that the TrackingView try to filter the country description with the country num…




(UD08_StartZip_c >= N’H1B2E5’) AND (Country_Description = N’5’)




When you say that the filter doesn’t work, do you mean that is isn’t reducing the records or that it’s not returning any records at all?
Are you able to provide some screen shots showing your setup for the BAQ and tracker? It’s hard to know what we’re diagnosing.

Maybe also try just a single field filter at a time too just to eliminate possible conflict with others.

Hi Andrew,

The filter doesn’t work (I tried with one filter field) because he’s trying to filter the country description with the country num which doesn’t make sense (I checked in the tracing log). Finally, I solved my issue by removing the default combo added by Epicor and added one by myself.