Debugging Kinetic Customizations via Chromium

Hey there beautiful people! I was wondering if anyone knew of a way to debug Kinetic customizations. In the “Getting Started With Epicor Application Studio for Tech Users” recorded webinar (Sign In), it was mentioned that there is a flag you can set on the client to debug Kinetic customizations via the chromium debugger (see timestamp 53:10 in the recording).

There used to be a “command line” Technical Reference guide but when I go to Technical Reference guides on EpicWeb, I don’t see one for 10.2.700. Does anyone know what the flag the presenter mentions is?

In the sysconfic.json file in inetpub/wwwroot/{EPISERVER}/Apps/ERP/home there are a few debug flags but I haven’t ever had them work for me.

I’ve always just launched the the Kinetic app in Chrome and use the Developer Tools in there.

1 Like

Just launch the web version of it and do the F12 debug.

1 Like

Thank you both for taking the time to respond. Forgive this absolute noob question: how does one launch a Kinetic app in chrome? :sweat_smile:

I tried running Epicor Web Access but this didn’t seem to launch the Kinetic version of the form. I found a post which seemed promising: 10.2.600.5 Kinetic forms not working in TEST
but when I use I try going to the same URL (changing it to reflect our environment) I’m prompted for a “Tenant ID” rather than a username/password:

Will continue googling/poring over the docs in case I’ve missed something. It’s probably staring me in the face and I just haven’t realized it yet

Are you using Azure AD for your authentication?

You should be able to access http://localhost:12345/ and it will take you to a Remote Chrome Debugging Console if you have Epicor open (EO WebBrowser will enable it). (clicking on it on latest chrome throws me errors)

You can also enable some text file logging as well as change the Remote Debugging port by adding the following to your client .sysconfig under <userSettings>

      <RemoteDebugPort value="9876" /> <!-- set custom port if you have issues with 12345 -->
      <LogEnabled value="true" bool="" />
      <LogPath value="C:\epicor\debug\foldertologto" />
      <!-- <ExtraCommandLines value="--disable-image-loading" /> -->
1 Like

@hkeric.wci thank you so much that’s what I was missing.

@John_Mitchell we are not. I’m assuming this is a setting somewhere, but I may be barking up the wrong tree.

Thank you everyone who responded to my question - you all are great and I appreciate you taking time to help a stranger. Once I get gud I hope to return the favor lol