DMT Issues

I am trying to remove Materials using DMT. Today, after selecting Delete and then Process, it just sits there and does nothing. Hit cancel and it does nothing. So I have to use the task manager to get it to stop. Ideas on why this is doing that? I really do NOT want to remove all this one at a time.

Try a DMT file with just a couple of rows, or even just 1 row. Maybe it takes a lot longer per row than you think.

And are you removing Mtl from Jobs or BOMs?


Just sits on zero percent. I have only two lines and still just sitting. Crazy!

I assume an ECO is required to change the BOM, via DMT. Did you create an ECO just for this DMT process?

And there are quite a few steps (and behind the scenes processing) required to remove material from a BOM. So I would expect that to go slow…

Yes, I use the same one all the time. All the others go through just fine. IDK.

So just one particular BOM?

I was just doing a test and got a “hexadecimal value 0x1E, is an invalid character” error.

I copied the XLSX file contents to a Text Editor, then back to the XLS file. And then it worked.

I haven’t done an BOM with DMT for a long time, but no issues before. For whatever reason, this is not going through. Guess by hand I go. Nothing in the text editor stood out as an potential issue.

I was able to remove a Mtl from a BOM with just the following fields


I pulled that data from a query of PartMtl (which doesn’t have the Plant field)

I have the same fields.
Company, PartNum, RevNum, MtlSeq, MtlPartNum, Plant, ECO

Are you sure you’r only trying to change approved BOM’s? It might be getting stuck on trying to checkout a BOM that’s not approved, or possibly already checked out to another ECO.

Field sequence can be important in DMT - behind the scenes it is running the BO calls in the same order that the UI screen would.

Suggest changing your column order to match Calvin’s example that works, see if it behaves differently.

Tried that to no avail. I did notice that after 30 minutes it was on 2%. So, its doing something but its VERY slow.

@markdamen @ckrusen I decided to let the DMT run and got this error after a while: Error: Exception of type ‘System.OutOfMemoryException’ was thrown.

Enable tracing to see what BO is failing with what data.

When I was getting the illegal char error, the trace log would abruptly end like…


Scrolling back showed it was in the



Use a brand new ECO Group and see if any difference…

Did you download an update for the DMT tool? We have noticed that may of the updates break the BOM DMT. We have to revert back to using the prior version.

@bw2868bond I am trying a new one, and so far still slow.

@utaylor No, I have not updated it. But I went ahead and removed it from the system files, and then took the back up one and put it in. Still slow.

@ckrusen I have the tracing on, so far, no hits to the system. However, it will take almsot an hour before it does much of anything.

I avoid updating DMT, like I avoid the “Sync Dataset” button in Report Style maint. :slight_smile:

1 Like

Apparently all I needed was to use the newer version of DMT. That worked with no issues.