DMT Part Attachments with single quote/apostrophe in file path

Hi everyone,

I’m trying to DMT part drawing attachments which have 's in the file path. If I try to upload them as is, I receive the error message “Syntax error: Missing operand after ‘s’ operator.” Obviously the issue is the single quote/apostrophe, but I’m not sure how to fix the problem.

File path for drawings= X:\CAD\Drawings\Standard-Products\PDF’s\

I tried doubling the single quotes (PDF’‘s), which is standard SQL practice for escaping this issue. I uploaded a few test records and no longer received the error message. However, the doubled quotes made it into Kinetic, so their file paths were X:\CAD\Drawings\Standard-Products\PDF’'s. I’ve tried searching for a solution here and on Google and didn’t find anything.

We use this file path in other programs, and several thousand parts already reference this file path in Kinetic (attachments created manually), so simply removing the apostrophe from the file path would be a lot of trouble. Is there a way to upload the data and keep the 's? Our current version is 2021.2.8 for reference.

Thanks,
Joel

Hi Joel,

We have had similar problems with attachments and filename ~ Double periods especially…one fellow here seems to like those.
We have a dialog / exception telling them not to use privileged characters in filename. I think I’d bite the bullet and change the path. It’s not a good idea to use privileged characters in the naming convention even if a system allows it IMO. It’s just a matter of time until you meet one that doesn’t allow it. I also don’t think you’ll find a workaround w Epicor.

Nancy

2 Likes

@joel7901 You can use File Attachment Maintenance to remove the apostrophe from the old or the new after DMT. It sends them to the task agent in the batch size groups. Comes in handy when you build a new server.

image

3 Likes