EDD New install 10.2.500.4-The system cannot find the file specified

Having a little trouble with a new EDD install on a 10.2.500.4 deployment and not sure where it’s failing.

I have the install path where I put my other extentions (E:\IIS) and I put the license file on the same drive.
For the app pool, I use a service account that is separated for the app side.
For the sql account, it looks like it’s using the service account of the app pool identified it will try to use this to connect. Interestingly, it connects just fine with this setting but not if I use a domain sql account that also has a sql login with the Sql Auth setting.

Assuming those configs are correct, when I go to deploy, I get this error “The System cannot find the file specified”. Pretty vague what it’s talking about.

Any ideas?

shooting in the dark here, have you tried relocating your lic file to something other than the root of the directory it in?

Hey Rob

Yes I tried from both a file share, the desktop of the user I’m creating the deployment with, and the root folder.

Re-installed the entire front end of 10.2.500, added the option for “Data Discovery” in the install phase, added my minor release, was able to un-install the in-progress installs of EDD and now I’m getting this:
“Failed to deploy Epicor Data Discovery Version string was too short or too long”

Goodness! This shouldn’t be that hard to install this thing

I think it has something to do with the SSL Domain name setting.

Is your SSL cert a wild card or a single hostname SSI?

it’s a wildcard cert

I don’t know if they ever fixed it but we had to register a new SSL cert as they weren’t supporting wildcard certs when we last tried.

If we do that, I assume it has to have it’s own entirely separate website then on IIS with a self signed cert? Since the wildcard is on the default site?

Sounds correct to me but there may be a way to have multiple certs on the same IIS mapping to different hostnames, just haven’t tried it.

Might be worth following up with Epicor support again to find out if the wildcard limitation is still there. You could also do a quick self-signed or Lets Encrypt cert to see if that gets you by this error for process of elimination.

I’ll give it a shot, thanks man

You’re welcome. Let us know how it goes and good luck. :slight_smile:

Hello. How did you resolve this issue? We are getting the same error installing EDD on 10.2.500.

Unfortunately, I didn’t. I decided to scrap it since I had already spent too much time dealing with it and Epicor had no help to be had :confused:

:frowning: ok thanks for the quick response…

1 Like

I might tackle again, and if I do I’ll let you know what I find

does KB0090991 any help? EDD -Knowledge Page - EpicCare.pdf (89.5 KB)