End Labor Activity not able to enter QTY

User cannot end Labor Activity because the field is grayed out.

Tried to complete activity in Job Adjustment and user is getting the following error.

> **Business Layer Exception**
> Part quantity total must equal operation quantity. Part Quantity is: 0 Op Quantity is: 1.0
> Exception caught in: Epicor.ServiceModel
> **Error Detail**
> ============
> **Correlation ID:** e39753d1-01ba-4203-85f0-2bd86a964266
> **Description:** Part quantity total must equal operation quantity. Part Quantity is: 0 Op Quantity is: 1.0
> **Program:** Erp.Services.BO.JobAdjustment.dll
> **Method:** CommitLaborAdj
> **Line Number:** 1037
> **Column Number:** 29
> **Client Stack Trace**
> ==================
> at Epicor.ServiceModel.Channels.ImplBase`1.ShouldRethrowNonRetryableException(Exception ex, DataSet[] dataSets)
> at Erp.Proxy.BO.JobAdjustmentImpl.CommitLaborAdj(JobAdjustmentDataSet ds)
> at Erp.Adapters.JobAdjustmentAdapter.CommitLaborAdj(JobAdjustmentDataSet ds)
> at Erp.UI.App.JobAdjustmentEntry.Transaction.Update(String which)

Kind of lost on what I am missing? Any help would be appreciated.



Check whether demand is linked to that job and JobHead.ProdQty has value.

JobHead and JobProd have 1 in the ProdQty.

Check JobPart as well

1 Like

Make sure the employee has the permissions set in employee maint to be able to do that.

1 Like

JobPart has qty 1 as well.

I am trying to do this a myself with system manager rights, and getting the same error/issue.

I found this, maybe it helps:
/// In order to be allowed the following conditions must be meet.
/// 1. Must be final assembly (AssemblySeq = 0)
/// 2. Must be the final operation.
/// 3. Job must have more that one end part defined or has one or more Parts with PartPerOp > 1

Also as mentioned above check the employee has report quantity permisions

1 Like

There is only one assembly.
We are in the last operation.
PartPerOp is = 1.

Is this a copart by any chance? If it is, you will need to go to the Coparts tab to enter the quantity.


not a co part. Thanks for the idea though.

We’ve run into an issue similar in the past. If our scheduler goes into the job and unreleases the job and removes it from the schedule and rereleases the job and reschedules the user is able to end the activity. It may be worth a try in your case.

user has report quantity checked.

Is the method for labor entry Time-Backflush? JobOper.LaborEntryMethod = X?

Check override job and see what you get.

It is set to Q.

Can you give me the results of below 2 queries? Change company and jobnum

select count(1) from Erp.JobPart where Company = ‘’ and JobNum = ‘’
select count(1) from Erp.JobPart where Company = ‘’ and JobNum = ‘’ and PartsPerOp > 1

1 Like

I stand corrected. Someone added a part as a copart, instead of as a material part. That did it.

Thanks!!! This helped me find that there was another part on the job.

1 Like

@knash They don’t call me the Queen of Copart for nothing :wink: LOL! Happy to Help!

And I hear she’s has a Cabaña too!