Enterprise Search

Using enterprise search, if I type “fishers”, the results include Fishers Fire Department. But if I type “fish”, it does not find Fishers Fire Department.

Is this a setup issue - indexing?

Thanks in advance.

have you tried to add a star after or before the word you looking for ? i.e. fish*

Yes - that works but takes very long. We have several companies and a lot of data. Thanks.

I use these two docs as a cheat sheet for searching. The second one has a whole section on Ent Search syntax.
Fun with Searches.pdf (343.6 KB) SearchinginEpicorERP.pdf (223.2 KB)



I run a script I got from support that rebuilds the full text catalog called FullTextFullIncremental.sql that we run weekly.

It runs sp_fulltext_catalog ‘‘tablename’’,’‘start_Incremental’’ on a bunch of tables. It does not make the partial search work w/o the * but our search seems to be pretty quick.

hey @gpayne - you mind sharing that script?

I thought Epicor was indexing with full text based on their system requirements. They require the full text search role to be installed on the SQL server that Epicor uses.

Since it is from support I can’t post it here, but suffice it to say that it is the line I posted for every table in your ES in the admin console.

@chaddb I think this just keeps the search database up to date with new data.

The ES database?

the full text search data