EPICOR is Offline popup on some machines, others work

Hi All,

During the install process for the e10 fat client we’re seeing success on some windows 7 boxes where others fail. That is we’re installing the exact same e10client.exe from our server and one windows 7 box works and the other doesn’t. The box that doesn’t work doesn’t show the available config files during the install process where the box that does work shows available config files. The failure mode on the box that doesn’t work is “Epicor is offline”. Finally on the box that fails if we turn on active directory it solves the problem(the install works). I think this tells us we have some kind of an authentication / permission problem on the windows 7 box that doesn’t work. Can anyone point us in the right direction on what windows 7 network settings need to be configured? If helpful we’ve done basic checks like verifying both boxes can resolve the server name via ping(DHCP, DNS, and network connectivity are working without active directory).

Do your active directory user name have spaces on them? (some of them)?
Ah sorry I didn’t read the whole thing. So one of the things that Epicor installer does is create a local file in your local temp folder which uses your user ID as part of the path if your user ID has spaces it won’t work correctly.

So if you are not using Active Directory I wonder if your user name has spaces or something funny?


you are good. We do indeed have spaces in the username on the box that doesn’t work :slight_smile: I’ll verify…

I submitted this is a bug a couple of years ago but I’m certain it’s not a too priority lol

Thanks Jose, that did improve things. When installing on the win7 box that doesn’t work I now see all the config files. Unfortunately I’m still seeing the same error. Please note I renamed the computer and the account to only have lower case letters. Also, each time I start the client I see an windows error(see below). Finally I ran an md5 hash of the config files on the working and non-working boxes and the config files are identical. Any pointers / suggestions?

@josecgomez is the man, I actually found the answer in an old post on this forum from him as well. For anyone else with this issue below is what Jose wrote the solution was:

This resolved the issue for us.

1 Like

If you do not have a domain I recommend switching to https binding.
This will fix the issue for everyone regardless of AD or not

Thank @josecgomez. I’m just getting involved, IT has been working with a consultant to get E10 installed up until now. I understand they were having difficulty getting the SQL server and E10 server(Microsoft 2016 Server) authenticating with each other. They turned on active directory on the servers and that fixed the issue. That lead to this thread where we were having problems authenticating between some win 7 clients and the server. Anyway, now that I’ve given a bit of background(our servers use active directory to authenticate, but our clients are not part of a domain). What do you recommend for our client authentication(https binding, etc)?

https binding for sure.

Thanks again @josecgomez! I’ll talk to IT about this today. From a high level what is the difference and why is https(I’m familiar with https, but not in the context of Epicor) binding preferred? Where do we configure e10 to use https binding?

Sorry for all the newbie questions - you guys are awesome :slight_smile:

1 Like

Because without Active Directory the net.tcp Windows Channel binding will fail authentication (as you saw)

Thanks Jose. For now we’re thinking of leaving windows machines in workgroups(don’t setup a domain/active directory) to minimize the number of changes / complexity we introduce. Later on down the road I hear there are a lot of benefits to active directory so we may pursue it, but decouple the e10 upgrade from the active directory project.

Thanks again for all your help!

@josecgomez we are using the credential manager to store domain authentication username / passwords, as we don’t have active directory setup. We just received a report that an E10 machine that was working stopped working and the cause is the the username / password for the domain disappeared from credential manager. I realize this is Windows specific and not Epicor, but curious if you’ve ever come across this or have any recommendations?

We’re considering Active Directory and the additional complexity and cost that comes with it, but if we can get credential manager to work reliably it would sure be nice to keep things simple.