Error- No more resources

Don’t know if you already got your answer, but I saw this as I was searching in answer books for an issue of mine.

Greg Payne


PG Increase the -n parameter error for 8.00 and 8.03 (748)


When trying to log into Vista/Vantage, the following error message occurs:
'Out of resources try a larger -n'

This error may also occur in the Event Viewer of the client trying to login to Vista/Vantage.

This error means that an attempt was made to exceed the limit for the number of users making an active connection to the database. Increase the -n parameter.

This message means that more connection have been attempted for the Open Edge database than it is currently set to allow. These connections include ODBC connections, Vista/Vantage users, MES users, and any other connection to the database.

There are configurations that need to be done for both the Database and the AppServers.

For applications using Open Edge 10.0B, the -n parameter is defined in the Progress Explorer Tool in the Server Group properties (MfgSysGroup and ODBCGroup), and summarized in the Default Configuration properties of each database.

For example:
MfgSysGroup has:
Number of Servers: 12
Min Clients per Server: 4
Max Clients per Server: 4

ODBCGroup has:
Number of Servers: 20
Min Clients per Server: 1
Max Clients per Server: 2

The -n parameter is defined by the "maxclientsperserver" multiplied by the numberofservers in the MfgSysGroup and ODBCGroup for each database. In the example above, the -n is set to 48 users for the the MfgSysGroup and 40 users for the ODBCGroup.

The Default Configuration properties screen must be a total of these as follows:

MaxServers = numberofservers (MfgSysGroup) + numberofservers (ODBCGroup) + 1
So in this example Maxservers = 12 + 20 +1 or 33

Maxusers = maxclientsperserver x numberofservers (MfgSysGroup)
+ maxclientsperserver x numberofservers (ODBCGroup)
So in this example Maxusers = (4 x 12) + (2 x 20) or 88

The number of AppServers set to run should never exceed the Maxusers for the MfgSysGroup. In the example above, Maxuser for MfgSys80 is 48 (4 maxclientsperserver x 12 number of servers.) So the combined Maximum Servers of all AppServers should not exceed 48. The number of AppServers can be checked by totalling the Maximum Server setting for each AppServer.

AppServers pool:
Under MfgSys80 Appserver Properties->Agent->Pool Range
Initial number of servers to start: 5
Minimum Servers: 5
Maximum Servers: 15

Under MfgSys80ProcessServer Appserver Properties->Agent->Pool Range
Initial number of servers to start: 1
Minimum Servers: 1
Maximum Servers: 1

Under MfgSys80TaskAgent Appserver Properties->Agent->Pool Range
Initial number of servers to start: 1
Minimum Servers: 1
Maximum Servers: 1

For this example, the number of AppServers would be 17 (15+1+1). Since this is less than the 48 for the Maxusers of the MfgSysGroup, configuration is done.

Once these numbers are correct, stop the AppServers and the DB. When they are stopped, restart the DB and the AppServers for the changes to take effect.


From: [] On Behalf Of brenda mohr
Sent: Tuesday, January 15, 2013 9:01 AM
Subject: RE: [Vantage] Error- No more rescources

It is supposed to be in the downloads section. It takes me forever to find anything on that site as well.


From:<> [<>] On Behalf Of Kimberley White
Sent: Monday, January 14, 2013 11:54 AM
Subject: Re: [Vantage] Error- No more rescources

Do you know where it is on the site? Is it easy to find? I have been o nteh site but can't find anything.
Thanks Kim

From: brenda mohr brenda@...<> >
Sent: Monday, January 14, 2013 11:45 AM
Subject: RE: [Vantage] Error- No more rescources

On the Epicweb there is a system performance tuning guide. It should
provide suggestions on how to manipulate your mfgsys file. -n is a
setting w/in that file.


From: [] On Behalf
Of faepigrl
Sent: Monday, January 14, 2013 12:26 AM
Subject: [Vantage] Error- No more rescources

Our server crashed last week and we had to rebuild and reload everything
on the same server just new drives. We are getting many strange
issues.... The one that I need the most help with is the following: "The
Server or the system has no more rescources. Try larger -n. (748)"

What is -n and how can I fix this? It seems like maybe I just set
something up wrong.

THanks kim

[Non-text portions of this message have been removed]

[Non-text portions of this message have been removed]

[Non-text portions of this message have been removed]


The information contained in this communication, including attachments, is privileged and confidential. It is intended only for the exclusive use of the addressee. If the reader of this message is not the intended recipient, or the employee or agent responsible for delivering it to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify us at 727-578-6280 and immediately delete the communication.

"This (document/presentation) may contain technical data as defined in the International Traffic In Arms Regulations (ITAR) 22 CFR 120.10. Export of this material is restricted by the Arms Export Control Act (22 U.S.C. 2751 et seq.) and may not be exported to foreign persons without prior approval form the U.S. Department of State."

[Non-text portions of this message have been removed]