Error when trying to view Change PO suggestions


I am getting an error on the Change PO Suggestions screen. I hit the binoculars, then hit Search and an error that states it cannot find the PORel_UD table. It is true, this table does not exist but can I find and correct the object that i supposedly looking for it?

I looked at a client and SQL trace but could not find the answer.

Thank you,


Make sure your Data Model is in sync in UD Column Maint. Were UD Columns added to PORel at one point, then deleted?

1 Like

Is the search defaulting to a BAQ or QuickSearch?


Try using the Basic search tab

I didn’t add any UD columns to the PORel table. But is there any place where I “look” at the data model?

I get the error when I hit Search on the Basic search…

Are there any BPM’s enabled for the highlighted BPM?


Look in user defined column maintenance.


Go to

Then in Extended User Defined Table Maint, click the search, and you’ll see all the UD Ext tables

As you can see in mine, I have a UD Ext table for POHeader, but none for PODtl or PORel



Unlike, (but worth ruling out) …

If there is a test environment on the same app server
AND the Production (aka LIVE) system and the test system were both installed in the same directory on the client computer,
AND the test environment has the PORel_UD

The files on the workstation may have been updated to match those required for the test environment.

The LIVE and the Test Environment has installed on different folders on my PC and none of them have the PORel_UD.

Have you tried clearing the client cache?

Does this happen to other users and on other workstations

Yes, I cleared the cache and no change. I tried with my account on another workstation and I still have the issue. But I found out that the behavior depends on the site. We have 6 sites: I have no issues with 4, in 1 site I have an error that mentions PORel_UD and and in the last one I also have an error message but it does mention PORel_UD (same object though)…

You don’t get the error until you hit the Search button, correct?

Maybe try regenerating the PO Suggestions, with the option to build from scratch.

If you can, try recycling your app pool. Is this on a production environment and just started today at random?