Field Setter Pre-Processing not working?

I am just double checking some things before launching an application integration, but I noticed that one of the BPMs involved is not working properly.

Basically, if the conditions are met on the pre processing BPM of Quote.Update, I use a Field Setter widget to set a custom DateTime field value to null.
This was working when I tested it (it must have, otherwise I would have made it work surely! :wink: ) but testing it now shows that even though the logic is routing correctly, the custom date field value is not being cleared.

The Message from the False side shows “false” if the logic wasn’t met, otherwise it falls through to a different message that says “true”. When I perform the test, it works as expected, but it’s just not clearing the QuoteHed.ProdForDate_c field like it’s supposed to.

Any ideas?

Change “All Rows” to “Changed Rows”.

Hey Jason, I tried that too with the same results.

That’s a date field, is that date field nullable? If so you may not be able to set it to null.

It is nullable. I have a secondary routine that runs on a schedule that does the same thing, except in that i set the field null via code. That secondary routine works just fine, and I swear this one was too, but apparently not

I have also tried setting the date to “Today” via BpmFunc.Today() and it doesn’t take either

I also verified that clearing that date field via uBAQ works just fine


Ever get this to work? I found this today.

I set the date on a UD date field immediately after a condition box and it would not set the day. A test message popped up just fine. But the date wouldn’t set unless it went through the message first. I finally got it to work by putting empty condition block (with no conditions) in between and it worked. Dunno.

Here’s what it looks like:

For what it’s worth.


1 Like

Hacky and weird, I do wonder why that works. Thank you for sharing!