Flash player settings for Vantage 8 help files - solved

Found the cause of the problem myself.

The bad behavior of the help system is caused by using the FQDN
(fully qualified domain name) of the server in the "deploymentServer uri"
setting in the .mfgsys config file.

We always use the FQDN, so the deployment server can be found
across domains in a WAN, using DNS.

So if I change

<deploymentServer
uri="\\deploymentserver.mydomain.local\epicor\mfgsys80" />

to

<deploymentServer uri="\\deploymentserver\epicor\mfgsys80" />

then the help system works fine again.

Pim

> Did anyone notice that since some update of Adobe/Macromedia's
> Flash Player, Vantage 8 help files fail to display properly?
>
> This happens if clients access the help files using a UNC URL, which is
> the default for Vantage 8 installations. Somehow, the Flash Player
> thinks the SWF files are on a different server than the HTML files.
> A security feature in newer players prevent Flash from displaying
> such objects. What you will see is that the help text itself displays
> fine, but the navigation menu on the left is missing. No error message
> is seen.
>
Did anyone notice that since some update of Adobe/Macromedia's
Flash Player, Vantage 8 help files fail to display properly?

This happens if clients access the help files using a UNC URL, which is
the default for Vantage 8 installations. Somehow, the Flash Player
thinks the SWF files are on a different server than the HTML files.
A security feature in newer players prevent Flash from displaying
such objects. What you will see is that the help text itself displays
fine, but the navigation menu on the left is missing. No error message
is seen.

I would think this is a bug in Flash player, so we can't really blame
Epicor for this, other than for choosing this technology in the first
place.

Meanwhile, all possible workarounds I can think of have their problems:

1. downgrade to an older Flash player
2. wait for a fix from Adobe
3. use http URL's instead of UNC file URL's
4. mess with Flash Player security settings

These are the problems I see with each of these workarounds:


1. downgrade to an older Flash player

This may reintroduce severe security bugs, and is a pain to
perform. Once done, users will be nagged to death pushing them
to upgrade again, triggered by every website they visit.


2. wait for a fix from Adobe

Yeah, right.


3. use http URL's instead of UNC file URL's

Yes, this fixes the problem. But it requires setting up IIS or Apache
and changing all .mfgsys files.

And, somehow Vantage Help works differently with http URL's
than with file URL's. For instance, when http URL's are used,
Vantage help automatically looks for help files in the current
Vantage language, which is not helpful if your Vantage software
is translated, but your help files aren't.


4. mess with Flash Player security settings

This is really awful. Adobe requires you to visit their site on
the Internet just to change a local setting! That is what
happens if you right click "settings" from a flash applet and
proceed to "advanced". No Internet access? Tough luck...

Then, in advanced settings, you can enter trusted URL's.
No way to trust complete Internet Explorer Zones, like the
Intranet zone. Settings are stored separately in Internet
Explorer and Firefox. And where are they stored? Can't
find them in the registry, otherwise one could force changing
settings in a logon script.

But now the really hard part. How do you enter a UNC file
URL in the security settings applet? Given that my help files
are on \\deploymentserver\mfgsys80\Help , I tried entering
that literally, then using forward slashes, than a "file:" prefix
and then various amounts of extra forward slashes in front of
the server name. Finally file://///deploymentserver/mfgsys80/Help
(yes, those are five consecutive forward slashes) would work
in Firefox, but not Internet Explorer, and thus not in the Vantage
Help browser...

Boy do I hate Flash ...


5. care less about Flash navigation

Oh, well, whatever... Everybody going for this one?

Pim