Help! Running into very obscure error while importing open job assemblies! Running mock trail for golive weekend. Not going live on Monday - ths is a test run. Just getting stuck

Help! I’m running a “mock” go live upload of our Vantage data this weekend and running into a very weird error with open job assemblies.

Receiving LOTS of errors with the proverbial “Object reference not set to an instance of an object” Any ideas?

it’s causing about 10% of my records (so far) to error out. It looks like once it hit’s one error, it causes every remaining assembly for that job to error out until the job number changes.

any ideas?
Jeff Henslee
M-B Companies Inc.

I’m also getting a ton of Invalid Unit of Measure errors too.
Table Msg: Invalid Unit of Measure. almost 98% of our parts are EA - especially those we manufacture. Can’t dream of why this is happening?

Very strange.

Verify the UOMs are loaded in this database instance. (Sometimes we forget tables :slight_smile: )
Are you loading all three fields for UOM? Inventory, Sales, Purchase

Are you in the right site for the job? Also, check sequencing… And
parent assembly records to be sure those are valid

I was not aware that the DMT (for jobs) needs to be done (by Plant)
I can try…

The job headers went in all at once (did not change plants) I can try.
Great Suggestion.

Epicor 10 is case-sensitive. Make sure your Company ID and Plant are the correct case.

IUM should not be included when importing Job Headers - although it appears to be a field you may update, in truth, it isn’t allowed in the UI so it should be excluded in your DMT import files.

Yes, all 3 field shave been loaded into the Part Master. However, in the Job Assemblies table, there is only one IUM field. there is a weight UOM field - but that should default from the part master.

No change - still receiving a TON of Object reference not set to an instance of an object error(s).
I exported assemblies for job for 1 plant and then tried importing.
no change

Are the jobs engineered? Are the methods approved for the revisions you are importing? Can you manually create one of the jobs? If all else fails, shoot me an email and we can connect offline. - this is not a solicitation for consulting services. Just a friendly helping hand.

If you,go into the job and manually create an assembly, are you able? I
tend to work backwards. Sometimes you can replicate the error in the ui
and isolate the issue… It would be my first step to trouble shoot this.

As others have mentioned, I see this error whenever a key field is not loaded before the record being loaded by DMT. Case can be and issue too as previously mentioned. Do what Andrew said, do one by hand. You’ll usually get a better error message.

Mark W.

yes - was very strange. Made an assumption and got burned (literally).
apparently you can add an assembly to a job and identify a part number that isn’t on the part master table.
NEVER even thought that was possible.
I’m off to the races again - unfortunately lost some time trying to find the actual error.

1 Like

any chance you could mark this as solved…It may help someone in the future.