InSite Manifest on 9.04 or 9.05?

We're testing 9.05 now but we would like to install InSite Manifest.
How difficult is it to upgrade or should we wait?

Thanks!!!

Mark W.