Issue after 10.2.500 Update

After updating in .500 in our DEV environment, if we change the language, Epicor automatically closes.

Does anyone have encounter such problem?

I ran into the same issue on 10.2.500.3. Just started looking into it this morning.

Seems to have something to do with elevated permissions - at least for me. I started the client with “Run as Administrator” and it worked to generate the proper resource files.

1 Like

Right on! Run as Administrator works.

Although, it is not a permanent solution. Still searching.

Thanks @danbedwards

So far, didn’t find the bug.

If we first start Epicor in Admin mode and change the language everything works fine. Then, I delete the language folder in the Client., restart Epicor in normal mode, changing the language doesn’t offer any problem.

It’s like, in Admin Mode, Epicor is writing something somewhere that stays and when we restart in normal mode, everythng works fine.

Is that your observation @danbedwards.

This issue is resolved in 10.2.500.5 under ERPS-125537. The problem was caused by enhanced logging added to the Client in the Language Satellite Assembly creation routines. Logging was added to trap more information - both error and informational.
Depending on the physical client installation location and Windows user permissions, the changes made for the enhanced logging could require Windows Admin User privileges - that requirement has been addressed with the 500.5 update and Admin privileges will not be required.


Thanks @Rich.