Issues Verifying Customizations - 10.2.600.8

Hey Epigurus,

I’m in the process of installing 10.2.600 on a new vm (upgrading from 400), and I’m getting many “object reference…” errors while verifying customizations via customization maintenance.

image

generally followed by

image

After hitting “Verify All”, I have to click through these errors many times. It’s a little concerning seeing this many errors, but it looks like the customization are still working as far as I’ve tested.

Has anyone else experienced these errors or have any idea why I’m getting them?

I’m also wondering about the “Valid For” field in customization maintenance. I see that it prepends a “w” to the version when there is a warning:

image

What does the “f” prepended to the version of a passing customization indicate?

image

Any input would be greatly appreciated!

“W” is warning and “F” is failed.
There are likely code issues that need to be cleaned up or orphaned objects that need to be deleted.

1 Like

Any idea why it would still say pass in the status field with an f in the version?

It seems to be related to the MES customizations. What’s strange is I created a new customization on MES without anything added to it, and it is still throwing those errors when I verify it.

Some errors are simply that it can’t test the screen properly (like sub-screens).

Gotcha, that makes sense. I went back and tried to verify a blank/no-code MES customization in versions 10.2.300 and 10.2.400 for testing purposes, and got a new error:

Application Error

Exception caught in: Ice.Lib.EpiClientLib

Error Detail 
============
Message: Object reference not set to an instance of an object.
Program: Ice.Lib.EpiClientLib.dll
Method: ConfigureXxxDefRowStandardColumns

Client Stack Trace 
==================
   at Ice.Lib.Customization.CustomizationVerify.ConfigureXxxDefRowStandardColumns(XXXDefRow defRow, VerifyCustomizationContext verifyContext, String validationMessage)
   at Ice.Lib.Customization.CustomizationVerify.TestCustomization(XXXDefRow defRow, VerifyCustomizationContext verifyContext, TimeSpan timeSpan)

Not sure what the effects of the errors are since the customizations are working and the customization maintenance screen claims they pass (without prepending the “f” to the version). I went ahead and opened a support case.

Did you manually clear your client cache?
Close Epicor and delete the C:\ProgramData\Epicor*-808 folders.

Hadn’t tried that one yet, didn’t change anything unfortunately.