Main Appserver not starting Error

Upgrading from 9.05.607a to 9.05.702a
SQL db

While trying to start the main appserver to update the lic file to the 702a one, I am not able to get the main appserver to start. I noticed in the server logs for the main appserver an error " CRC LicCnfg does not match CRC in as/startup.p. Try recompiling (1896) see attached screenshot. I also get a very similar error when I try launching the admin tools, "CRC for VntgVer does not match CRC in SqlVer.p. Try recompiling (1896). I have searched on here and found a somewhat similar thread that mentioned the incorrect install files were used based on the db type, ISO(standard) vs. UniCode. Now everything I look at in our db points me in the direction that our db is ISO(see screenshot showing column descriptions) BUT this error comes back on here as the wrong 905702 install files were installed. I did use the 905702-S install file which is for the standard SQL type. But I’m really wondering if I need to uninstall that and try using the UniCode 905702 install files. I was able to successfully run the schemachange to get our db level to 905700 if that makes any difference. The screenshot showing the appserver log is with verbose logging enabled using the -debugalert switch.

Any help is greatly appreciated!
Thank you.




If you’re using standard but it was Unicode you’re gonna have a bad time. They are different versions.

Yes I agree. That’s why I posted the screenshot from ssms showing what I believe is a non-Unicode db for our environment, so that was the update software I installed. But the error seems to point to a Unicode db. That’s why I’m confused and looking for any insights.

What’s the database collation? This error is pretty indicative of a unicode db non unicode install.

If you’re trying to indicate unicode vs not looking at the varchar vs nvarchar I’m pretty sure you can still use varchar in a unicode collated db.

I did not look at the collation, that is a great point. I will look at it and post my results. Thank you for reply.

Below is a screenshot of the collation. I believe this is just the default one most commonly used.


That is a unicode capable collation, I assume this isn’t production so just re-install with unicode version of Epicor and see what you get. I’m about 99% sure that error is likely due to a mismatch between unicode and not