-Mm parameter

Rick,
I was having the same issue, these two posts from Troy and Michael worked
for me.

>There are two files which set the -Mm size (which is the packet size for
data being transmitted from the server to the >client workstation).

>One file (N:\progress\startup.pf) is where Progress gets the Packet size
for the server. This can also be set in your >startup command (in
ProControl) or in the -Mm field in Progress Explorer tool. From your error
message, the server has a >-Mm of 4096. This is what it should be.

>The other file (N:\Vantage\Db\vantage.pf) is the file your client uses for
setup information. There should also be a -Mm >setting here which matches
your -Mm above. If there is no -Mm there, it probably defaults to 1024.
Add a -Mm 4096 to a >line in that file. (Use Notepad to edit the vantage.pf
file).

>This should fix your problem.

>Troy Funte
>Liberty Electronics

>Check the -Mm in the .PFs you are using. Sounds like PROGRESS\STARTUP.PF
>has -Mm 4096 and VANTAGE\DB\VANTAGE\DB\VANTAGE.PF has -Mm 1024. You could
>be using different PF files to these, to be sure look at the .VTG your
>shortcut is pointing to.

>The Performance Tips on ERANET recommend 4096.

>Michael Miles
>Continental Conveyor

Shirley H. Graver
(End User)
Systems Administrator
Rubber Associates Inc.



[Non-text portions of this message have been removed]
This past Friday night I did a memory and hard drive upgrade to our Vantage
server in preparation for installing 5.0. I figured while I had everything
shut down I would try some database tuning and see what happened to
performance. My reference was an answer book article: XA Performance Tips -
Server and Workstation, Page: 340.10MPS.

I adjusted the -B parameter and -Bt with no problems. I also added the -Mm
parameter for network message buffer size. As per the instructions, I added
-Mm 4096 to both the \dlcsrv\startup.pf and also the client in
\vantage\db\dcdv7.pf. I fired up Vantage - version 3.0 by the way - and
went home. After coming back from some vendor visits yesterday I had many
messages waiting for me. Running report builder reports was fine, but when
running custom reports users would get the error:

Report Builder: Unable to connect to database. Database error is: Server
has -Mm parm 4096 and client has 1024. They must match. (1150)

I came in last night and removed the parameter from the startup.pf and
changed dcdv7.pf back to 1024 and everything is fine. Any ideas what
happened? Paul usually looks up these errors for me, but he is where most
everyone else probably is this week - Perspectives.

Thanks,

Rick