More Native Assemblies/References in one environment

Hello All,

Thank you for taking the time to read my post. I’m having an issue with a customization I’m exporting from one environment into another (DEV to LIVE) on version

When I import the customzation into LIVE I get a compile error saying that some assembly and references are missing for UD21impl, UD20impl, and DynamicQueryimpl.

they say:
The type or namespace name ‘UD21Impl’ could not be found (are you missing a using directive or an assembly reference?)
The name ‘UD21Impl’ does not exist in the current context

then it says the same thing for UD20Impl and DynamicQueryImpl

I go into the customization and I see those are listed under the Custom Assembly Reference Manager. So, it appears those are in the customization. The more confusing part for me is the Native Assemblies, in the Dev customization (which works) I see 4 native assemblies (customer shipment entry) but when I go to the LIVE customization (which does not work and gives error related to the assemblies) I see 40 native assembles listed. This leads me to believe there is something odd going on with the importing of this customization. Other customizations of the screen in LIVE have 4 native assemblies, it is just the one with 40 listed.

I’ve tried re-exporting / re-importing and I get the same error. I tried clearing my cache then re-importing and still get the issue. I’ve also tried saving the customization as a new name in DEV then exporting and importing it as a different name in LIVE and I still got error.

Has anyone else faced this issue? Any information is appreciated.

Just curious if you exported/imported via both Customization maintenance and/or while you were in Dev Mode?

i did. using the full extensions in the code fixed the error, but it was a weird issue.