Multiple BAM using same field

Aaron,

That does work, I have already combined a couple of my .p. But is this
working as designed or this solution just a workaround?

Everything was working fine until recently and I called Epicor and they
did not indicate that I was writing BAMs improperly, but of course I
called them two weeks ago and they have not given me an answer yet.

Thanks,

Rich


-----Original Message-----
From: Aaron Hoyt [mailto:aaron.hoyt@...]
Sent: Friday, March 17, 2006 4:28 PM
To: vantage@yahoogroups.com
Subject: RE: [Vantage] Multiple BAM using same field.

Sure Rich,

Use each .p file to call the next .p file. You can nest .p files within
a
single BAM.
You might want to create a "master" .p for that trigger, and then use it
to
call the other .p files in the order you choose. You can also set a
setting
(not sure off the top of my head though) for each called procedure to
define
if the next call waits until the first is complete, or runs them both
together.
Good luck,
Aaron Hoyt
Vantage Plastics

-----Original Message-----
From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com]On Behalf
Of RICH WAGNER
Sent: Friday, March 17, 2006 3:36 PM
To: vantage@yahoogroups.com
Subject: [Vantage] Multiple BAM using same field.


I have several BAMs that are triggered off the same field. They have
worked in the past, and I am not sure when but they quit working. They
all seemed to run fine by themselves but a couple of them will not work
if they are active at the same time as another alert that is triggered
off the same field. They may have quit when I applied a patch or when
we moved Vantage to a different server, I am not sure. Epicor does not
have an answer for me yet either. Does anyone have any suggestions?



Thanks,



Rich Wagner

BAW Plastics

Phone: (412)384-3100

E-Mail: rwagner@...





[Non-text portions of this message have been removed]



Useful links for the Yahoo!Groups Vantage Board are: ( Note: You must
have
already linked your email address to a yahoo id to enable access. )
(1) To access the Files Section of our Yahoo!Group for Report Builder
and
Crystal Reports and other 'goodies', please goto:
http://groups.yahoo.com/group/vantage/files/.
(2) To search through old msg's goto:
http://groups.yahoo.com/group/vantage/messages
(3) To view links to Vendors that provide Vantage services goto:
http://groups.yahoo.com/group/vantage/links
Yahoo! Groups Links










Useful links for the Yahoo!Groups Vantage Board are: ( Note: You must
have already linked your email address to a yahoo id to enable access. )
(1) To access the Files Section of our Yahoo!Group for Report Builder
and Crystal Reports and other 'goodies', please goto:
http://groups.yahoo.com/group/vantage/files/.
(2) To search through old msg's goto:
http://groups.yahoo.com/group/vantage/messages
(3) To view links to Vendors that provide Vantage services goto:
http://groups.yahoo.com/group/vantage/links
Yahoo! Groups Links
I have several BAMs that are triggered off the same field. They have
worked in the past, and I am not sure when but they quit working. They
all seemed to run fine by themselves but a couple of them will not work
if they are active at the same time as another alert that is triggered
off the same field. They may have quit when I applied a patch or when
we moved Vantage to a different server, I am not sure. Epicor does not
have an answer for me yet either. Does anyone have any suggestions?



Thanks,



Rich Wagner

BAW Plastics

Phone: (412)384-3100

E-Mail: rwagner@...





[Non-text portions of this message have been removed]
Sure Rich,

Use each .p file to call the next .p file. You can nest .p files within a
single BAM.
You might want to create a "master" .p for that trigger, and then use it to
call the other .p files in the order you choose. You can also set a setting
(not sure off the top of my head though) for each called procedure to define
if the next call waits until the first is complete, or runs them both
together.
Good luck,
Aaron Hoyt
Vantage Plastics

-----Original Message-----
From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com]On Behalf
Of RICH WAGNER
Sent: Friday, March 17, 2006 3:36 PM
To: vantage@yahoogroups.com
Subject: [Vantage] Multiple BAM using same field.


I have several BAMs that are triggered off the same field. They have
worked in the past, and I am not sure when but they quit working. They
all seemed to run fine by themselves but a couple of them will not work
if they are active at the same time as another alert that is triggered
off the same field. They may have quit when I applied a patch or when
we moved Vantage to a different server, I am not sure. Epicor does not
have an answer for me yet either. Does anyone have any suggestions?



Thanks,



Rich Wagner

BAW Plastics

Phone: (412)384-3100

E-Mail: rwagner@...





[Non-text portions of this message have been removed]



Useful links for the Yahoo!Groups Vantage Board are: ( Note: You must have
already linked your email address to a yahoo id to enable access. )
(1) To access the Files Section of our Yahoo!Group for Report Builder and
Crystal Reports and other 'goodies', please goto:
http://groups.yahoo.com/group/vantage/files/.
(2) To search through old msg's goto:
http://groups.yahoo.com/group/vantage/messages
(3) To view links to Vendors that provide Vantage services goto:
http://groups.yahoo.com/group/vantage/links
Yahoo! Groups Links