New Installation of 10.1.500.14 and added Database

WHen I add the database, it only allows me to add to the default location for the MDF and LDF, which is in the C directory.

When I change the path I get a Access Denied, that it cannot create the files in the path. I am able to create a text file remotely, the drive and folders are shared since I am able to create the file.

If I create the production, test and pilot on the C, then back up and restore the mdf and ldf to a different location, do I need to edit any config files?

As long as the restored database name is the same as the one that was backed up, do not need to change any Epicor configuration files.

Do the mdf and ldf need to be in the same directory? It works fine when I leave the default path.

It appears that you’re trying to use a UNC path for the .mdf/ldf which wouldn’t be recommended for a few reasons and would ultimately require changing the user account that starts the SQL server service.

Within the EAC’s create database window, click Actions > Configuration.

If you change the MDF and LDF location to the absolute local paths on the SQL server (e.g. d:\mssql\data and e:\mssql\logs), does that allow you to successfully create the database?

It does not either. Same access denied, which is why I use the UNC path.

I had I:\DB and L:\LOGS with the same error. The only time it is working is with the default as you have in the image above

I find that when I add a fresh drive to Windows (e.g. I:, or L: or T:, or whatever) I have to make sure that the domain user account we run everything under (here we use has full read/write permissions on those new drives. The EpicorAdmin service account is like an Epicor convention that they have you setup when they do your implementation.

That has been confirmed.

I even created a new directory and gave EVERYONE full access.

I created a local account as well

Are you a domain admin? What level of permissions does the SQL account you are using have? What type of drive is this iSCSI or DAStorage or internal? In windows everyone permission does not always mean everyone, you sometimes are contending with NTFS vs Share permissions. Is this drive that you get “access denied” on a shared drive and if so what are the permissions there and if it’s hosting your MDF and LDF why is it shared?

Yes to all the admin rights. Some say I have too much access. :slight_smile:

But was also having issues with back ups. I have two versions installed on the server. SQL12 and SQL14. I am able to do backups to the non C;| drives in 2012, but have issues on 2014. Read up on the net and I saw this

for backups done via SQL Executive/SQL Agent

SQL Server agent was not started on 2014. Started it and now I can do backups on the non C: drives. I will try to create the DBs now from the EAC.


The Reluctant DBA.

Well still cant create a DB from the EAC to a non C: drive on SQL2014.

What kind of permissions does your SQL user have are you using windows auth or sql auth?


I has to do with the installation. I mentioned that I have two instances of SQL on the server. 2012 and 2014. I just used the EAC to add the 2012 instance and I am able to create the DB on the I:\EPI-DB\ and L:\Logs\

I didnt do the installation, but there is something not right with now. I can say is is not a E10.1.500.14 setup issue.

I am using my domain account to create the DB. I have also tried using the sa account. Any thoughts on the SQL side what it could be.

are you doing this from a remote pc/server and do you have sql management studio for 2014 installed on whatever device you are doing this from?

Epicor Application is on CCCAEPI10 VM server
SQL is installed on CCCASQL01 VM server and can connect to the CCCASQL01\EPI10 instance with Studio 2014

I can create the DB on the C:\ but not on the I or L.

And within Management Studio on the actual SQL server you can’t, as SA, create a database on a drive other than C?

Could be a permission issue on the Service Account.

Learning here

Have you contacted support? This could be a rabbit hole. The drives you are trying to save to are all on the up and up healthy? You can save anything else to them just not the DBs

Thanks for the support, I think I got it.

I needed to add MSSQL$EPI10 to the security and I finally figured out that I need to put NT SERVICE\MSSQL$EPI10.

I am able to create a Test DB now and also use EAC to create the new database.

Thanks for helping out.

Awesome! Make sure if everything goes through at this point to mark your last post as the solution. Thanks!