ODBC Database problem - 6.1

This should do it..

# servers = 10
Max clients per = 1
Min clients per = 1

Bob Morgan


--- In vantage@yahoogroups.com, "Moore, Jim (Anniston)" <jmoore@...>
wrote:
>
> Since support never got back to me on this, I think on my own I may have
> figured out where the problem is, but still need advice on what to set.
>
>
>
> In Progress Explorer and under properties for the ODBCgroup, I have this
> set:
>
>
>
> Client type: SQL only
>
> Service name or port number: 6140
>
> Number of servers: 0
>
> Message buffer size: (grayed out, but 1024)
>
> Reporting interval: (grayed out, 1)
>
> Maximum clients per server: 0
>
> Minimum clients per server: 1
>
> Maximum dynamic port: 5000
>
> Minimum dynamic port: 3000
>
>
>
> The settings for my defaultservergroup are quite different.
>
>
>
> 4GL only
>
> 6100
>
> 10
>
> 4096
>
> 1
>
> 4
>
> 4
>
> 5000
>
> 3000
>
>
>
> We have 29 users and 10 DC license.
>
> DB size is approaching 3 GB.
>
> Server is 3 GHz with 4 GB ram.
>
>
>
> We will have probably less than 8 people using ODBC and even less at one
> time.
>
>
>
> Any suggestions on what to set the number of servers at on my ODBC group
> setting?
>
>
>
> Thanks,
>
>
>
> Jim Moore
>
>
>
>
>
> From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf
> Of Moore, Jim (Anniston)
> Sent: Tuesday, August 07, 2007 10:15 AM
> To: vantage@yahoogroups.com
> Subject: RE: [Vantage] ODBC Database problem - 6.1
>
>
>
> I'm sorry, my mistake in my email. The live server IS on port 6140 and
> is different from the copy-live DB on 6150.
>
> From: vantage@yahoogroups.com <mailto:vantage%40yahoogroups.com>
> [mailto:vantage@yahoogroups.com <mailto:vantage%40yahoogroups.com> ] On
> Behalf
> Of John Sage
> Sent: Tuesday, August 07, 2007 9:58 AM
> To: vantage@yahoogroups.com <mailto:vantage%40yahoogroups.com>
> Subject: Re: [Vantage] ODBC Database problem - 6.1
>
> Jim,
>
> If both databases are on the same server, you should not try to use port
> 6150 for both ODBC connections. Try changing the port number of your
> copy database (using Progress Explorer), then restart it and try your
> ODBC connection.
>
> john
>
> Moore, Jim (Anniston) wrote:
> >
> > I have ODBC setup and working fine with no issues on the copy-live DB
> > using port 6150. The ODBCGroup for the copy-live DB is set to Both 4GL
> > and SQL.
> > I can connect via SQL Explorer, create users, change permissions and
> can
> > connect via a client (Excel) and see tables ect.
> >
> > However when it came time to Setup ODBC on our live DB using port 6150
> I
> > cannot connect via SQL Explorer.
>
> [Non-text portions of this message have been removed]
>
>
>
>
>
> [Non-text portions of this message have been removed]
>
I have two active 9.1D databases, 1- Our live production DB and 2- Our
test or as we call it our copy-live database.

I have ODBC setup and working fine with no issues on the copy-live DB
using port 6150. The ODBCGroup for the copy-live DB is set to Both 4GL
and SQL.
I can connect via SQL Explorer, create users, change permissions and can
connect via a client (Excel) and see tables ect.

However when it came time to Setup ODBC on our live DB using port 6150 I
cannot connect via SQL Explorer.
The live database was set to SQL only and I got the brokers not allowed
message.
I changed to Both 4GL and SQL, rebooted and it still did not work.
I changed back to SQL only, stop and started the DB and still no
connection.

I did follow the ODBC instructions with regard to running the ODBC fix.
I just cannot connect so that I can use the 61ODBCsecurity.txt file.

Does anyone have a suggestion to what I can try next? Support has not
been able to help so far.
The defaultServerGroup is set to 4GL only for both databases.

Thanks in advance for any advice or help offered.

Jim Moore

------------------------------------------------------------------------
------------------------------
"This email message is for the sole use of the intended
recipient(s) and may contain proprietary and/or confidential
information for which such intended recipients(s) may have
an obligation to treat as proprietary. Any unauthorized review,
use, disclosure, or distribution is strictly prohibited. If you are
not the intended recipient, please contact sender by reply
email and destroy all copies of this e-mail."
------------------------------------------------------------------------
-----




[Non-text portions of this message have been removed]
Jim,

If both databases are on the same server, you should not try to use port
6150 for both ODBC connections. Try changing the port number of your
copy database (using Progress Explorer), then restart it and try your
ODBC connection.

john




Moore, Jim (Anniston) wrote:
>
> I have ODBC setup and working fine with no issues on the copy-live DB
> using port 6150. The ODBCGroup for the copy-live DB is set to Both 4GL
> and SQL.
> I can connect via SQL Explorer, create users, change permissions and can
> connect via a client (Excel) and see tables ect.
>
> However when it came time to Setup ODBC on our live DB using port 6150 I
> cannot connect via SQL Explorer.
I'm sorry, my mistake in my email. The live server IS on port 6140 and
is different from the copy-live DB on 6150.



From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf
Of John Sage
Sent: Tuesday, August 07, 2007 9:58 AM
To: vantage@yahoogroups.com
Subject: Re: [Vantage] ODBC Database problem - 6.1



Jim,

If both databases are on the same server, you should not try to use port
6150 for both ODBC connections. Try changing the port number of your
copy database (using Progress Explorer), then restart it and try your
ODBC connection.

john

Moore, Jim (Anniston) wrote:
>
> I have ODBC setup and working fine with no issues on the copy-live DB
> using port 6150. The ODBCGroup for the copy-live DB is set to Both 4GL
> and SQL.
> I can connect via SQL Explorer, create users, change permissions and
can
> connect via a client (Excel) and see tables ect.
>
> However when it came time to Setup ODBC on our live DB using port 6150
I
> cannot connect via SQL Explorer.





[Non-text portions of this message have been removed]
Since support never got back to me on this, I think on my own I may have
figured out where the problem is, but still need advice on what to set.



In Progress Explorer and under properties for the ODBCgroup, I have this
set:



Client type: SQL only

Service name or port number: 6140

Number of servers: 0

Message buffer size: (grayed out, but 1024)

Reporting interval: (grayed out, 1)

Maximum clients per server: 0

Minimum clients per server: 1

Maximum dynamic port: 5000

Minimum dynamic port: 3000



The settings for my defaultservergroup are quite different.



4GL only

6100

10

4096

1

4

4

5000

3000



We have 29 users and 10 DC license.

DB size is approaching 3 GB.

Server is 3 GHz with 4 GB ram.



We will have probably less than 8 people using ODBC and even less at one
time.



Any suggestions on what to set the number of servers at on my ODBC group
setting?



Thanks,



Jim Moore





From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf
Of Moore, Jim (Anniston)
Sent: Tuesday, August 07, 2007 10:15 AM
To: vantage@yahoogroups.com
Subject: RE: [Vantage] ODBC Database problem - 6.1



I'm sorry, my mistake in my email. The live server IS on port 6140 and
is different from the copy-live DB on 6150.

From: vantage@yahoogroups.com <mailto:vantage%40yahoogroups.com>
[mailto:vantage@yahoogroups.com <mailto:vantage%40yahoogroups.com> ] On
Behalf
Of John Sage
Sent: Tuesday, August 07, 2007 9:58 AM
To: vantage@yahoogroups.com <mailto:vantage%40yahoogroups.com>
Subject: Re: [Vantage] ODBC Database problem - 6.1

Jim,

If both databases are on the same server, you should not try to use port
6150 for both ODBC connections. Try changing the port number of your
copy database (using Progress Explorer), then restart it and try your
ODBC connection.

john

Moore, Jim (Anniston) wrote:
>
> I have ODBC setup and working fine with no issues on the copy-live DB
> using port 6150. The ODBCGroup for the copy-live DB is set to Both 4GL
> and SQL.
> I can connect via SQL Explorer, create users, change permissions and
can
> connect via a client (Excel) and see tables ect.
>
> However when it came time to Setup ODBC on our live DB using port 6150
I
> cannot connect via SQL Explorer.

[Non-text portions of this message have been removed]





[Non-text portions of this message have been removed]
Jim,



ODBC only...min servers 2, max servers 3. Epicor recommends 4 clients
per server. Try that and see if that helps.



Also, what are your DB Buffers set to? That will make a difference as
well.



Thanks,



Jason Claggett

Microsoft Small Business Specialist

MCP #3856159

2W Technologies, LLC

312.533.4033 x8039

jason@...



From: vantage@yahoogroups.com [mailto:vantage@yahoogroups.com] On Behalf
Of Moore, Jim (Anniston)
Sent: Thursday, August 09, 2007 3:27 PM
To: vantage@yahoogroups.com
Subject: RE: [Vantage] ODBC Database problem - 6.1



Since support never got back to me on this, I think on my own I may have
figured out where the problem is, but still need advice on what to set.

In Progress Explorer and under properties for the ODBCgroup, I have this
set:

Client type: SQL only

Service name or port number: 6140

Number of servers: 0

Message buffer size: (grayed out, but 1024)

Reporting interval: (grayed out, 1)

Maximum clients per server: 0

Minimum clients per server: 1

Maximum dynamic port: 5000

Minimum dynamic port: 3000

The settings for my defaultservergroup are quite different.

4GL only

6100

10

4096

1

4

4

5000

3000

We have 29 users and 10 DC license.

DB size is approaching 3 GB.

Server is 3 GHz with 4 GB ram.

We will have probably less than 8 people using ODBC and even less at one
time.

Any suggestions on what to set the number of servers at on my ODBC group
setting?

Thanks,

Jim Moore

From: vantage@yahoogroups.com <mailto:vantage%40yahoogroups.com>
[mailto:vantage@yahoogroups.com <mailto:vantage%40yahoogroups.com> ] On
Behalf
Of Moore, Jim (Anniston)
Sent: Tuesday, August 07, 2007 10:15 AM
To: vantage@yahoogroups.com <mailto:vantage%40yahoogroups.com>
Subject: RE: [Vantage] ODBC Database problem - 6.1

I'm sorry, my mistake in my email. The live server IS on port 6140 and
is different from the copy-live DB on 6150.

From: vantage@yahoogroups.com <mailto:vantage%40yahoogroups.com>
<mailto:vantage%40yahoogroups.com>
[mailto:vantage@yahoogroups.com <mailto:vantage%40yahoogroups.com>
<mailto:vantage%40yahoogroups.com> ] On
Behalf
Of John Sage
Sent: Tuesday, August 07, 2007 9:58 AM
To: vantage@yahoogroups.com <mailto:vantage%40yahoogroups.com>
<mailto:vantage%40yahoogroups.com>
Subject: Re: [Vantage] ODBC Database problem - 6.1

Jim,

If both databases are on the same server, you should not try to use port
6150 for both ODBC connections. Try changing the port number of your
copy database (using Progress Explorer), then restart it and try your
ODBC connection.

john

Moore, Jim (Anniston) wrote:
>
> I have ODBC setup and working fine with no issues on the copy-live DB
> using port 6150. The ODBCGroup for the copy-live DB is set to Both 4GL
> and SQL.
> I can connect via SQL Explorer, create users, change permissions and
can
> connect via a client (Excel) and see tables ect.
>
> However when it came time to Setup ODBC on our live DB using port 6150
I
> cannot connect via SQL Explorer.

[Non-text portions of this message have been removed]

[Non-text portions of this message have been removed]





[Non-text portions of this message have been removed]