Off Topic - SOAP and Sharepoint

We have a Quality Management System (ETQ Reliance) that we are implementing. One of the “features” is the ability to publish documents directly to your Sharepoint Libraries at defined workflow stages. It does this using SOAP web services. (Note I am not a developer and maybe talking sideways here). It seems when we trigger the workflow the system attempts to publish the document on cue however we receive a “SOAP” error as follows: The system can not establish a connection to the Sharepoint Environment - Exception of type Microsoft.Sharepoint.SoapServer.SoapServerException was thrown.

The developer did a WebEx with us and tried using SOAPUi to connect to our Sharepoint environment (Office 365) and could also not connect. They, therefore, say it is our issue and not theirs. We can not find any settings to our knowledge that would prohibit access to the library. We use a privileged login ID/Pwd, allow legacy authentication for that user and can add a file to the library using drag and drop with those user creds.

Does anyone have any experience with external connections to Sharepoint 365, SOAP or any insight? My vendor suggests calling Microsoft but we don’t really know what to ask.

Thanks

Hello Keith,

As with most interfaces on the web today, the preferred method of working with cloud resources is REST. With Office 365, you want to look at the Microsoft Graph. I didn’t see REST mentioned on their website though. Microsoft deprecated the SOAP API in SharePoint a while ago (4-5 years?) so ETQ should have some replacement if they still support SharePoint as a repository.

Mark W.

Web services are still working and we use them in attachments. Including O365 SP Online.

This is true. If I understood correctly, he’s having an issue with the 3rd-party quality package. It should work but they’re not supporting him.

Quick question @Olga, I have an open case about attachments and O365 SP Online (CS0001787262).

Can the current Web Services for SP attachments use Azure AD for authentication? It appears that only Basic Auth works at the moment.

Thanks! And Happy New Year! :clinking_glasses:

Mark W.

1 Like

Thanks, Mark/Olga, full disclosure, our vendor is supporting us as far as their product is concerned. As I mentioned their support person used SOAP Ui to try and access our instance and could not. I don’t know much about this so I am not
sure what questions to ask Microsoft. Or try to access it myself with a REST call.

The error you show us the common exception. Is there any additional error codes or other text?

You mean share same token that is created when user logs into ERP with Azure AD binding? I don’t think it that is implemented now.

1 Like

Unfortunately not. That is why it is difficult to determine if/what is incorrect in our SharePoint settings or software configuration.

Thanks for taking the time to comment.

Keith

Do you know the URL the app tries to connect to? Can you open it in browser?

This is from a REALLY long time ago so proably a stretch but… I did have external connection issues with Epicors old product Clientele which was using SOAP. In that case the problem turned out to be NAT - for some reason the Clientele setup expected real IP addresses, didn’t like translation. I was able to get a fix from Epicor for that.

Yes, we actually configure that in the app. I also tried a development SharePoint site, same issue.

Thanks, we don’t use NAT but we do use SSO and that may be creating a similar issue. This is why I hate cloud based things, no control or visibility.

You mentioned my old Clientele baby? :slight_smile:

That was the first .NET product for Epicor and the basis for a lot of future applications especially ERP. A lot of Ctel is still around under the covers.

Mproof?

Before they partnered. We worked with them a ton in the early days.

Clientele was the first .NET product I was exposed to at that site too.
CRM eventualy prompted their move to Vantage from the old world of Dataworks, HPUX, Unidata, Preview & Wintegrate.

Worked a bit with them in relation to an E9/ITSM integration…It was fun, of course hindsight is a great thing, and I would have done it way differently now.

1 Like

Was the issue resolved? I’m experiencing the same Soap issue while trying to connect to Sharepoint

1 Like