Part Details not loading

Working in my test environment, I’ve restored a copy of my live data into my test database. Live environment is working 100%, no issues.

However, in my test when i open up Part Entry and try to load in a part number, the details don’t load in and remain blank. Tried redoing restoring the database to a previous backup but no luck. I’m thinking it may be a corrupt database/data, or something with a method call.

This is only affecting the Part entry/tracker window

Hi Martin,

I know this may be a silly question, but I’m only bringing up what I’ve seen happen with some of our users … when you input the part number in the field, did you hit tab? Also, does selecting the part via part search bring in the record?


Pulling in the part number with tab/search menu works as expected, but nothing gets loaded in, ie. all fields remain blank/empty.

Hi Martin,

How about doing a BAQ to ensure you have your data in there for the part table and part plant table as expected?


Data is in the tables, i’m thinking its something to do with the update/retrieve method, tried on multiple machines, same issue. So i don’t think it’s an installation error.

Have you tried deleting the ProgramData/Epicor directory for the Test environment?
running Part entry in base mode?
disabling customizations in web.config.
deleting all personalizations?

This KB KB0050119 has stuff to consider also.

1 Like

What am I deleting in ProgramData? I don’t have any folders/files that specifically say its for the Test Environment

Ran it in base mode and deleted personalizations, no luck.

@mkfernandez I also don’t see anything below the server that shows which appserver, but as long as they are not running on the PC you can wipe the entire directory and it will be rebuilt when Epicor opens.



Are there any customized fields in the part table ?

Yes, but even in the base version it doesn’t load.

@gpayne , deleted the folder, still no luck.

@mkfernandez Have you tried part entry and tracker from other menus?

yes, all other menus experience the same issue, kinda starting to think we’ll just need to deal with it, it’s only affecting our test environment so it’s not a pressing issue.

Try “Regenerate data model”. It may fix the issue.

Did this numerous times beforehand, just did it again and it fixed my issue. No idea why though.

1 Like

When you say the data is in the database, you need to check partplant, partcost, partwhse as well, not just the part table.
If you did a restore from the production database to your test database, then the data will be there.
If there we issues with UD Fields, they would be seen as a requirement to regenerate the data model.
In your live environment, are there any security settings that are specific to the part related services? Things like field level security or process security?