Permission Error during Migrate Epicor Database Step

In working through a migration from Progress to Epicor 10.1.500.11 we have reached a step in the process which seems to be caused in part at least by a bug in the process, but may not. Hoping someone has seen and solved this issue elsewhere.

Current State - All on Test servers:

  • Progress 9.05.700C upgraded successfully to 9.05.702A
  • Scrub Fixes Identified and successfully applied
  • Epicor 10 environment ready, including the SQL server
  • Progress server set with Epicor Administration tools
  • All backups performed and ready for the “Migrate Database” step

In our first pass attempt we discovered that the Migrate Database process is attempting to create the INTERIM SQL DB in the path designated by “Output Folder” on the “Source Database” tab. Is this by design, or an bug/error?

After trying several things, we were able to get a bit further, but always error out in the process due to a Permission exception - despite running as full admin account on the server.

Ed,

Does you issue bear any resemblance to this issue we had during our E9 to E10 conversion years back?

Our setup is :

A) Epicor 9.05.702A Server with Database
B) Epicor 10 SQL Server
C) Epicor 10 App Server

I was running the Epicor Admin Console and performing the DB migration on (C), where the source database was on (A) and the target E10 database was on (B). I used Windows Authentication with a domain admin user. When it got to the Task ID 500-IceSystemTablesMigration it errored out with:

“Logon failed for NT AUTHORITY\ANONYMOUS user”

I tried switching the configuration to use SQL authentication and having the migration continue from that step but same errors popped up. Google led me to believe this error probably means there is some login multiple-hopping happening, so on a bit of a whim (and influence by this thread [SOLVED] SQL Database Migration Errors - NTLM, Kerberos, and an Epicor Utility - SQL Server Forum) I decided to try installing just the Epicor Admin Console on my new Epicor 10 SQL box (B) and start the DB migration over from there. This seems to have worked to get me by 500, but it seems like others would have run into this if the migration really can’t live through this slightly more complicated scenario than E10 App/SQL server all being on one box.

For us, the solution was to temporarily make this security adjustment on the SQL Servers involved:

Note: Since we are performing this step with 3 separate servers, it is necessary to give the “NT AUTHORITY\ANONYMOUS LOGON” account db_owner role access to both the source and destination database, at least prior to and during the migration. See this EUG Post: http://www.epicorusers.org/p/fo/st/post=28627#p28627

Here is the solution as presented by Jim Rogers in that EUG post, in case you don’t have access:

I just went through this scenario. If you go into the SQL Server Management studio on each of your DB servers and add a login under security for the NT Authority\Anonymous Login and give that user db_owner rights to both the source and target db, it will get you past this error.

Jim Rogers

Thank you Adam!

Question - was your migration from Progress DB?

We started initially with an A,B,C server setup like you describe, but have reduced to a Progress server with the Epicor 10 Admin tools installed - still pointing at a remote SQL server.

My next attempt was going to try with SQL server installed on the Progress server as well - but I will take a shot at the permission change you mention for the Anonymous logon account.

I appreciate the information and will update soon with results.

Ed

Error resolved by granting Explicit Read permission to the default SQL account per this article:

1 Like