Personalizations not automatically loading after upgrade to 10.2.700

I am currently testing an upgrade from 10.2.400 to 10.2.700. The new version is on a new virtual machine.
My user customizations for forms are not loading for the users. If I open the form in developer mode, the personalization is there, and I can select and use it, but once I close the form, and reopen, it does not use the personalization.
I have validated, and forced validation on some I am testing, and they pass.

Is there a step I am missing or had missed in moving the data to the new server? Do I need to enable something?

Personalizations have never survived well on version upgrades.

This gets better in Kinetic pages when you’re ready to go there.

BTW, why 10.2.700 when you could go to 11.1.200 (K2021.2) and still use the smart client but stay in the support window longer? :thinking:


Typically you dont have to do much besides address Personalization Warnings/Errors and then Validate or Force Validate them.

You might need to clear your cache folder. You may have ran a bad one it cached it and then Validated it and tried again - it may be trying to pull the cached version.

I also agree with @Mark_Wonsil why not go to 11.1.200 (NOT 11.2.100 since this one require SQL Upgrades among other things)

1 Like

I ran the ‘clear cache’ command in settings, still hasnt solved the issue.

Moved to that version to keep our customizations working correctly.

clear command doesn’t work you will have to close Epicor and look at your .sysconfig if you have a Custom Cache Path if not then its in C:\ProgramData\Epicor

Oh thanks. Checking now.

Cleared it, no luck.

Go to 2022 the difference between 700 and 2022 on classic is minimal, you might fight a handful of issues from the move to .NET 6 but don’t start in a setback. From my current 600 to 2022.1 I had to updated 3 customizations, 4 UBAQ, and 2 EFX libraries all due to .NET6 and I’m a HEAVILY customized company.

  • Force validate all personalization records in Customization Maintenance
  • Close Epicor
  • Delete the folders in %PROGRAMDATA%/Epicor
  • Try again

I typically delete all personalizations from upgrade to upgrade to prevent any unforeseen issues, they can really go sideways on you our cloud actual issues.


I will take a look at it. Thanks for the info.

Just spoke with Epicor support, this is tied to the bug from version 10 where if a customization was not assigned to ‘all companies’ it would not deploy correctly. We only use 1 company. Never thought to assign to all.

There is a workaround to redeploy to the current company.

1 Like