Purchase advisor with "Other" parts in 10.1

Has anyone else had any issues with using the purchase advisor for non-inventory parts? We have some shop supplies that our purchaser wants to see the history and with the upgrade from 10.0 to 10.1 we get an error that attBatch cannot be null. I have a call in to service, but if anyone else has a quick fix on this that would be helpful.

Here’s the error message.

Application Error
    Error Detail 
    Message: Failed to Auto-Search; Possible invalid primary adapter defined for Erp.UI.PurchaseAdvisorEntry
    Inner Exception Message: Column 'AttBatch' does not allow nulls.

    Inner Exception 
    Column 'AttBatch' does not allow nulls.

       at System.Data.DataColumn.CheckNullable(DataRow row)
       at System.Data.DataTable.RaiseRowChanging(DataRowChangeEventArgs args, DataRow eRow, DataRowAction eAction, Boolean fireEvent)
       at System.Data.DataTable.SetNewRecordWorker(DataRow row, Int32 proposedRecord, DataRowAction action, Boolean isInMerge, Boolean suppressEnsurePropertyChanged, Int32 position, Boolean fireEvent, Exception& deferredException)
       at System.Data.DataTable.InsertRow(DataRow row, Int64 proposedID, Int32 pos, Boolean fireEvent)
       at Erp.UI.App.PurchaseAdvisorEntry.Transaction.createPartListViewRow()
       at Erp.UI.App.PurchaseAdvisorEntry.Transaction.GetPurchaseAdvisorData(Boolean partExists)
       at Erp.UI.App.PurchaseAdvisorEntry.Transaction.adapterInvokeSearch(SearchOptions o)
       at Ice.Lib.Framework.EpiMultiViewTransaction.InvokeSearch(SearchOptions opts)
       at Erp.UI.App.PurchaseAdvisorEntry.PurchaseAdvisorEntryForm.OnClickSearch(SearchOptions options)
       at Ice.Lib.Framework.EpiBaseForm.DoAutoSubscriberSearch(String sColumn)
       at Ice.Lib.Framework.EpiBaseForm.autoSubscriberSearch()

Do you by chance have Tracing enabled? I had a similar issue years ago and it was a bug with the Client Tracing Flag. This is likely NOT the issue but just came to mind when I saw the error.

No, the error came up for our purchaser first, who would never have tracing on. I just tried again with my tracing off and same error.

Any idea about the invalid primary adapter? Could that be an upgrade issue with it not pointing to the new version?

I can’t find the AttBatch column anywhere, but I don’t really know exactly where to look either…