Quick Job Entry - Finite Scheduling

I’m wondering if this is a bug or expected behaviour. When creating a job through Quick Job Entry and selecting the Scheduled checkbox, the job is scheduled with infinite capacity. If I reschedule the job and select the option for Finite Capacity, then it obeys the resource Finite Capacity option.
I’ve tried all settings of Finite Horizon for Resource/Group and the behaviour is the same.
I would have thought there should be an option in Company Configuration to control the default, but I can’t find any.
One strange thing is that, going through the example in Embedded Learning (multiple resources with same capability but all with finite capacity), it indicates that the jobs should be distributed to the available resource then a job is already scheduled on another resource, but this isn’t happening either. I tried following the example exactly.
So, I guess, is anyone else using the Quick Job Entry and, if so, are you able to get it to schedule with finite capacity?

What is your finite horizon? Is it set at the system level, or the resource level?

1 Like

I set the horizon to 39, first at site then at all levels (site, resource group and resource) and it doesn’t seem to make a difference.
I probably should mention that this is on a 10.2.600 instance.
I’m pretty sure the issue comes from the quick job entry submitting the schedule request without finite scheduling since a normal schedule job request from job entry (not the quick one), when selecting finite capacity, works as expected.

I once made a process that automatically called the QuickJob process, and if I remember correctly, it did not finite schedule like we wanted. I had to call the schedule process as a secondary procedure to get it finitely scheduled.