RDD Report Criteria is greyed-out

I have read some threads on this forum that mentions how to pass BAQ Parameters into a SSRS Report. It mentions about modifying Report Data Definition (RDD) and then adding the Report Criteria. For me, this area is completely greyed-out. If I try to Duplicate the existing RDD to a new name, it throws me an error “Record not found”.

This is version 10.2.400 and I have all the necessary permissions. What am I missing?

Try closing the RDD Maint window and then re-launching it. Sometimes the UI gets out of sync if a referenced DB record (like the BAQ ID your RDD uses) has changed.


Can’t tell from your screen shot, but have you already added the BAQ as a datasource? I don’t think the Criteria options are enabled unless the BAQ has parameters.

Thanks, I am getting closer but still not there. You were correct about adding the “DataSource”. When I added that, the Report Criteria had shown. I filled everything out. When I run the report from the Menu, I do not see any place I can enter the Parameter Value. The Report Errors saying “No Records Found” probably because the BAQ has an un-passed parameter value.

Clearly, I am still missing something else.

I recall that you have to specify which Criteria set the report will use. It might be in the Report Style Maintenance.



Yes. I did that. I now get a dialog window to appear when running the report, but get SSRS runtime errors.

Make a backup of the RDL used by that style, then press the Sync Dataset button.

Normally I would say to NEVER press that button. But looks like you might need to here.

The backup of the RDL was in case the sync process goes horribly wrong - which it often does with built-in Epicor reports

1 Like

I synced the report and I still get the errors on the DataSet(s). I even opened the RDL and did a Test Connection and Refresh fields on ALL the DataSets.

I used the BAQ Report Designer to initially build the RDL file. Perhaps if I captured the GUID and manually ran the RDL inside the Report Designer, it might offer some better insight. Other than that, I am out of ideas.

Are you trying to alter a BAQ Report RDD or create a new RDD using a BAQ as a data source?

Just re-read the post again and noticed that you said you used the BAQ Report Designer, so I am assuming that you are trying to alter a BAQ Report RDD.

Someone else can probably confirm, but you can’t use that functionality with a BAQ Report.

You need to create a new blank RDD and then add your BAQ to that. Then you can use the Criteria functionality.

Correct. I did the report as a BAQ Report using the BAQ Report Designer. I let the BAQ Report Designer create the RDL shell, then I used that to design the report. After everything was done, I forgot that the user needs to enter parameters.

Can I salvage what I have done?

I spent a lot of time on the RDL.

What should I do now?

I’m pretty sure the datasets in a BAQ Report’s RDL will differ from those in a RDD Based RDL. To salvage your current RDL, you’ll probably need to alter the datasets to match what the RDD generates.

You could also just use the criteria selections in the BAQ Report Designer. I don’t believe you can tie them to parameters, but you could delete the parameters and then replicate them in the BAQ Report.

So I need to add the Tables into the RDD and not bother with with the BAQ Query as a DataSource at all? I was pretty sure I have done BAQ Reports with parameters before.

There are 2 ways to create an SSRS report in Epicor. The old way is to create a BAQ Report based on a BAQ and Epicor will automatically create the RDD and Report Style. The way that most people do it now is to create the RDD manually as a blank RDD and then add in the BAQ. Then manually create the Report Style.

These two options are not interchangeable. You cannot combine the two approaches. What @ckrusen is saying is that if you want to salvage your SSRS report AND use the RDD Criteria functionality, you will need to create the new RDD and manually update the RDL to mirror the new dataset output.

Ok, forget the BAQ Report Designer. It seems like a quick for an end-user to do.

I already have the BAQ and the RDL is already done. I tried the approach of doing the RDD manually, picking the BAQ, the Criteria. Then I did the Report Style, there was a step to upload a report but that failed.

If doing the Report Style, how do I get it build the RDL on the Report Server to edit it?

If I do Create SSRS Report, it throws me a permissions error even though I am a System Administrator on the SSRS Site.

Do you have the “ReportTemplate” in your Custom Reports folder?

Yes. The RDL called ReportTemplate is located in the Custom Reports folder. Within the Report Style, Actions. Create SSRS Reports it throw me a permissions issue. I am a System Administrator on SSRS and can upload reports to that Custom Reports folder just fine if I use the BAQ Report Designer. I can also manually upload and download RDLs to that folder without any issues.

The permissions granted to user DOMAIN\USER are insufficient for performing this operation.
—> Microsoft.ReportingServices.Diagnostics.Utilities.AccessDeniedException:
The permissions granted to user DOMAIN\USER are insufficient for performing this operation.

Does an RDL for TE-WSR already exist in the reports/CustomReports “folder”?

Try entering reports/CustomReports/TE-WSR_2 for the Report Location before doing the “Create SSRS Report”

Yes, the file already existing but only because I did this – I downloaded the ReportTemplate.rdl and renamed it to TE-WSR and then manually uploaded it. I thought I could do the Sync Dataset, but that errored.

I just tried your suggestion of making a new Report Location with a different name. Then clicking Create SSRS Report throws me the SSRS pemissions issue.

Based on the Help, I am thinking that the “Create Report” only works for a BAQ Report.