Receipt AutoPrint not working due to not using SSO? But GenInv will work?

Hi all,

Testing out 2023.2.4 and working on our bartender labels. Our GenInv labels print out just fine with no issues BUT our GenRcpt labels do not due to it saying it needs to use SSO. On our Appserver we have the ICE Task Agent with a service account with the account set up as SSO in Epicor and requires SSO. It works as it should. Is there something that I am missing to why GenInv will print out fine every time for our bartender labels but GenRcpt will not due to it not using SSO? If I take off require SSO in Account security maintenance, it will work for about a minute before the password expires BUT it confirms that the labels and bartender is working fine…just seems to be an access issue on the backend. I have also tried to use the SSRS report RcptLabel and gives me the same error. Any ideas?

Here is the error message:

Failed to launch task to submit report. Error: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation.
—> System.UnauthorizedAccessException: You can only log on via single sign-on.